Getting a "invalid certificate" for iPhone app

  1. Woodencoasterfan
    Mar 25, 2014, 6:26 PM

    I'm getting a "invalid certificate" message when I try and visit my site ThemeParkFanatic from my iPhone. I'm already logged in and can access my site via the internet on my iPhone and my laptop but not the iPhone app. Is there something they or I can do about it?

  2. I am having the same problem.

  3. Same here. Had it yesterday and had to delete and reinstall app then same again this morning

  4. Is anyone going to help us

  5. Can anyone help I can't view my blog

  6. Woodencoasterfan
    Mar 27, 2014, 1:21 PM

    Well at least I know now that I'm not the only one having this problem, hopefully they'll get it resolved soon

  7. is dealing with an issue where some of their SSL certs are being incorrectly treated as invalid. Its a server-side issue that is being worked on and hopefully should be resolved quickly.

  8. I just started getting this today, or perhaps I just noticed it.

  9. I have been getting this for a few days now on my IPAD and on my husbands IPAD..

  10. I have the same problem. I have tried creating a new admin account, reinstalled the wp app and I have the latest versions of everything.

    From this forum I have understood that I should use my site's login info (and not the account's). None of them work though.


  11. @Angela Monroe,

    It looks like there is a problem with your site's SSL certificate, and this is the reason you are seeing that error.

    To talk to your blog, the app makes secure requests to (note the https)

    If you look at that page in a web browser like Chrome, you'll notice a warning message.

    You might want to contact your web host and ask if your site's SSL certificate needs updating.

  12. @ Folks hosted on and using custom domains.

    If you're still experiencing trouble connecting with the app, please try viewing your blog over https, not http. If you see a warning that your certificate is invalid you might want to check that your custom domain is correctly mapped.

    If everything looks like its mapped correctly, and you're still seeing a certificate warning in your web browser (not the app) then you might post in the support forum.

  13. Eric, I'm not sure I understand. When I choose "View Site" in the app, it doesn't appear to let me choose between http and https.

    I am not seeing a cert warning in my browser, only in the WP app.

  14. I'm still getting this and it's now been almost a week. When will this be fixed?
    It's only happening on the app. How do I check the http/ htttps on the app please.
    This problem only started after the recent updatw

  15. This started to happen to me today, it's annoying because I've tried all sorts to put it right and have had to update all my password/ usernames etc. makes me feel like an imposter on my own site !

  16. @jimgrey, @bizzimummy. I think my post could have been clearer. Please try viewing your blog in a web browser via https and see if you see a certificate error message.

    @bizzimummy, for you the URL is, and I see the cert warning when I check in a browser. Since you're hosted on using a custom domain, please check the documentation in that link I shared earlier and make sure your domain mapping is configured correctly.

  17. Eric, thank you for clarifying. I *do* get a cert error when I go to my blog using https on a browser.

    I appear to not have a way to manage my domain at - the button for that is missing - but I"ll take that up with support. Thanks.

  18. Eric, support tells me that sites do not support https on the front end. So it seems like the WordPress iOS app needs to not try to reach sites via https.

  19. My host said it was a memory issue and gave me more. Now the app works on my mobile!

    It might be more people with this issue so maybe there should be some kind of info somewhere? At least now there's my comment.


  20. My site works fine on a web browser.
    It also works fine on my iPad with the older version of wp app before the update

  21. Still having this and now can't preview posts or pages either

  22. Woodencoasterfan
    Apr 6, 2014, 12:29 PM

    Same here Bizzimummy1. I still can't view my site from the iPhone app and I'm getting the same message as well.

  23. All of my hosting, domain name, everything is handled by WordPress. The cert error and the inability to preview appear to be related ... But I don't know what I personally can do about it.

    WP please help me ...

  24. Someone from WordPress ... Please Help

    I have posted a log file, beginning from startup and new post creation at

    The log states that there is a certificate error, but I no longer see this message. Preview does not work for me.

    WordPress hosts my site. I have changed nothing.

    Someone please help.

  25. I got the Preview feature to work ... ONCE ... by adding a new site (my site as https://) and accepting the invalid certificate despite the warnings. The new site fails to appear. If I recreate it again as https I can get preview to work exactly one time.

    This is absolutely a bug on the WP server side.

  26. I have a work-around for the failing Preview command

    The cert error and the Preview failure appear to be related

  27. I have a work-around for Preview not working

  28. The work around works for me.
    I'm really annoyed that this was not fixed in the update it must be about 3 weeks now

Topic Closed

This topic has been closed to new replies.

About this Topic