Forums

Failed image upload from iphone app - i've tried everything, help!

  1. I'm trying to post photos to my 2 blogs, getting the following errors:

    1) Operation could not be completed. - NSXMLParserErrorDomain error 5. (this closes by itself quickly)
    2) Communication error - bad user name or password. (Click OK)
    3) Operation could not be completed. - NSXMLParserErrorDomain error 5. (click OK)
    4) The post disappears from the list of posts (until you click refresh)

    There are TONS of people having image upload problems, I've tried many of the suggestions.

    1) try upgrading wordpress (from 2.x to 3.0)
    nope, same problem.

    2) from admin page, remove settings->media values
    nope.

    3) next, add to .htaccess:
    AddType x-mapp-php5 .php
    nope, and now apache gives related errors.

    4) next, add to .htaccess:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    nope.

    5) try restarting apache.
    nope.

    6) i heard that reinstalling iphone app may fix it.
    nope.

    7) will http authentication help?
    nope.

    8) now i read that permissions may to blame
    change folder permissions to 777
    upload photo
    change folder permissions back to 755
    nope. kept it at 777, no luck.

    9) upgraded to iphone OS 4
    nope.

    Anything else I can try?!? Obviously I'm obsessed with getting this working. :> TIA!

    My blog is at http://blog.thedigitalmachine.com (and it's very devoid of photos atm!) :>

  2. Looks like the NSXMLParserErrorDomain error 5 means NSXMLParserPrematureDocumentEndError.

    But I don't see why an upload would stop in the middle. My php.ini file looks good to me, allows large uploads. I'm not getting apache errors. Hrmph, stumped.

  3. After adding the same .htaccess file mentioned above to my domain I'm having the same exact issue. Has anyone gotten this working yet?

Topic Closed

This topic has been closed to new replies.


About this Topic