Forums

Error occurred during saving

  1. I'm loving the updated WordPress app, but have seen an issue with it working on a client's website. I am able to add the site, see my old posts and posts that I've put into draft from another location, but when I start a post on the iPad and try to save it as a draft, I get a very succinct error message -- "Error occurred during saving".

    Any ideas?

  2. Hi movablebeast,

    Wow, that's not a great error message. :/

    You might try going to Me > Help & Support and enable Extra Debug, and try saving a draft again. Then go back to Me > Help & Support > Activity Logs and see if a more helpful error is captured in the Current log.

    If you want to share the log here we'd be happy to take a look.

  3. Thanks, Eric. I am pasting the Current log below:

    2015/12/09 12:11:57:019 WPAnalytics session started
    2015/12/09 12:11:57:032 ===========================================================================
    2015/12/09 12:11:57:032 Launching WordPress for iOS 5.7 (5.7.0.1)...
    2015/12/09 12:11:57:032 Crash count: 0
    2015/12/09 12:11:57:032 Debug mode: Production
    2015/12/09 12:11:57:032 Extra debug: YES
    2015/12/09 12:11:57:032 Device model: iPad6,8 (iPad6,8)
    2015/12/09 12:11:57:032 OS: iPhone OS 9.2
    2015/12/09 12:11:57:032 Language: en-US
    2015/12/09 12:11:57:032 UDID: F8154897-6701-4122-ADA5-E1B3444F7ED5
    2015/12/09 12:11:57:033 APN token: (null)
    2015/12/09 12:11:57:033 Launch options: (null)
    2015/12/09 12:11:57:033 All blogs on device:
    2015/12/09 12:11:57:035 <Blog Name: Other World Computing Blog URL: http://blog.macsales.com XML-RPC: http://blog.macsales.com/xmlrpc.php jetpack: 🚀✅ Jetpack 3.7.2 connected as UNKNOWN with site ID 5439935>
    2015/12/09 12:11:57:035 ===========================================================================
    2015/12/09 12:11:57:170 MediaService cleanUnusedMediaFileFromTmpDir
    2015/12/09 12:11:57:464 didFinishLaunchingWithOptions state: 1
    2015/12/09 12:11:57:470 <WordPressAppDelegate: 0x12463cf40> applicationDidBecomeActive:
    2015/12/09 12:11:57:617 !!! Attempted to create a revision of a revision
    2015/12/09 12:11:57:618 0 media items to check for cleanup
    2015/12/09 12:11:57:634 Feedback response received: {
    "feedback-enabled" = 0;
    }
    2015/12/09 12:11:57:891 !!! Attempted to create a revision of a revision
    2015/12/09 12:11:58:606 Failed checking muti-author status for blog http://blog.macsales.com: Error Domain=WPXMLRPCFaultError Code=401 "Sorry, you cannot list users." UserInfo={NSLocalizedDescription=Sorry, you cannot list users.}
    2015/12/09 12:11:59:655 Failed checking muti-author status for blog http://blog.macsales.com: Error Domain=WPXMLRPCFaultError Code=401 "Sorry, you cannot list users." UserInfo={NSLocalizedDescription=Sorry, you cannot list users.}
    2015/12/09 12:12:01:210 No instructions, do nothing
    2015/12/09 12:12:07:061 Helpshift Enabled
    2015/12/09 12:12:12:712 TracksService sendQueuedEvents completed. Sent 6 events.
    2015/12/09 12:12:25:844 Copying attribute author
    2015/12/09 12:12:25:844 Copying attribute authorAvatarURL
    2015/12/09 12:12:25:844 Copying attribute authorID
    2015/12/09 12:12:25:844 Copying attribute content
    2015/12/09 12:12:25:844 Copying attribute date_created_gmt
    2015/12/09 12:12:25:845 Copying attribute mt_excerpt
    2015/12/09 12:12:25:845 Copying attribute mt_text_more
    2015/12/09 12:12:25:845 Copying attribute password
    2015/12/09 12:12:25:845 Copying attribute pathForDisplayImage
    2015/12/09 12:12:25:845 Copying attribute permaLink
    2015/12/09 12:12:25:845 Copying attribute postID
    2015/12/09 12:12:25:845 Copying attribute postTitle
    2015/12/09 12:12:25:845 Copying attribute post_thumbnail
    2015/12/09 12:12:25:845 Copying attribute remoteStatusNumber
    2015/12/09 12:12:25:845 Copying attribute status
    2015/12/09 12:12:25:845 Copying attribute wp_slug
    2015/12/09 12:12:25:845 Copying attribute metaIsLocal
    2015/12/09 12:12:25:845 Copying attribute metaPublishImmediately
    2015/12/09 12:12:25:845 Copying attribute commentCount
    2015/12/09 12:12:25:845 Copying attribute geolocation
    2015/12/09 12:12:25:845 Copying attribute latitudeID
    2015/12/09 12:12:25:845 Copying attribute likeCount
    2015/12/09 12:12:25:845 Copying attribute longitudeID
    2015/12/09 12:12:25:845 Copying attribute postFormat
    2015/12/09 12:12:25:845 Copying attribute publicID
    2015/12/09 12:12:25:845 Copying attribute tags
    2015/12/09 12:12:25:845 Copying relationship blog
    2015/12/09 12:12:25:845 Skipping relationship original
    2015/12/09 12:12:25:845 Skipping relationship revision
    2015/12/09 12:12:25:845 Copying relationship comments
    2015/12/09 12:12:25:847 Copying relationship media
    2015/12/09 12:12:25:848 Copying relationship categories
    2015/12/09 12:12:25:924 !!! Attempted to create a revision of a revision
    2015/12/09 12:12:27:856 TracksService sendQueuedEvents completed. Sent 2 events.
    2015/12/09 12:14:54:439 <PostSettingsViewController: 0x1260bf230> viewDidLoad
    2015/12/09 12:15:13:743 <WPPostViewController: 0x1248a4400> savePost
    2015/12/09 12:15:13:760 Copying attribute author
    2015/12/09 12:15:13:760 Copying attribute authorAvatarURL
    2015/12/09 12:15:13:760 Copying attribute authorID
    2015/12/09 12:15:13:761 Copying attribute content
    2015/12/09 12:15:13:761 Copying attribute date_created_gmt
    2015/12/09 12:15:13:761 Copying attribute mt_excerpt
    2015/12/09 12:15:13:761 Copying attribute mt_text_more
    2015/12/09 12:15:13:761 Copying attribute password
    2015/12/09 12:15:13:761 Copying attribute pathForDisplayImage
    2015/12/09 12:15:13:761 Copying attribute permaLink
    2015/12/09 12:15:13:761 Copying attribute postID
    2015/12/09 12:15:13:761 Copying attribute postTitle
    2015/12/09 12:15:13:761 Copying attribute post_thumbnail
    2015/12/09 12:15:13:761 Copying attribute remoteStatusNumber
    2015/12/09 12:15:13:761 Copying attribute status
    2015/12/09 12:15:13:761 Copying attribute wp_slug
    2015/12/09 12:15:13:761 Copying attribute metaIsLocal
    2015/12/09 12:15:13:761 Copying attribute metaPublishImmediately
    2015/12/09 12:15:13:761 Copying attribute commentCount
    2015/12/09 12:15:13:761 Copying attribute geolocation
    2015/12/09 12:15:13:761 Copying attribute latitudeID
    2015/12/09 12:15:13:761 Copying attribute likeCount
    2015/12/09 12:15:13:761 Copying attribute longitudeID
    2015/12/09 12:15:13:761 Copying attribute postFormat
    2015/12/09 12:15:13:761 Copying attribute publicID
    2015/12/09 12:15:13:761 Copying attribute tags
    2015/12/09 12:15:13:761 Copying relationship blog
    2015/12/09 12:15:13:761 Skipping relationship original
    2015/12/09 12:15:13:761 Skipping relationship revision
    2015/12/09 12:15:13:761 Copying relationship comments
    2015/12/09 12:15:13:761 Copying relationship media
    2015/12/09 12:15:13:761 Copying relationship categories
    2015/12/09 12:15:13:907 post failed: The network connection was lost.
    2015/12/09 12:15:27:925 TracksService Error while remote calling: Error Domain=NSURLErrorDomain Code=-1017 "cannot parse response" UserInfo={NSUnderlyingError=0x125a9ad60 {Error Domain=kCFErrorDomainCFNetwork Code=-1017 "(null)" UserInfo={_kCFStreamErrorCodeKey=-1, _kCFStreamErrorDomainKey=4}}, NSErrorFailingURLStringKey=https://public-api.wordpress.com/rest/v1.1/tracks/record, NSErrorFailingURLKey=https://public-api.wordpress.com/rest/v1.1/tracks/record, _kCFStreamErrorDomainKey=4, _kCFStreamErrorCodeKey=-1, NSLocalizedDescription=cannot parse response}

    That "post failed: The network connection was lost" makes no sense since the device is connected via Wi-Fi and is not having network issues.

    Steve

  4. Hi @movablebeast

    Thank you for sharing the log, but I'm afraid it doesn't have any answers for us.

    The error is curious but I'm reluctant to speculate about its cause. However, if the error is happening with just a specific client's site, and the error can be reproduced on different devices it would suggest the cause is something server-side.

Topic Closed

This topic has been closed to new replies.


About this Topic