Forums

Crash When Uploading Pix

  1. I will admit that I didn't search the boards for so if this was already brought up and answered then I apologize now. When I upgraded (even with 2.6) every time I try to upload a photo the app crashes. The progress bar goes to the end and then the post is lost and the app closes. When I reenter the app the post is gone and if I try again by starting a new post and click "media" it shows the photo as being there. However, if I select the photo it only shows a blank black screen. If I delete it, the app crashes. I have already deleted the app and reinstalled it from the device. I am using an iPad running ios 3.2.2.... PLEEEASE help me :-(

    Or and it does the same thing with video as well.

  2. Hey there, sorry to hear you're having so much trouble with the app. Just want to be clear - are you using Version 2.6 or Version 2.6.1? We just released an update (literally an hour ago) that should resolve the issue you're describing.

    Let me know if you've upgraded to 2.6.1 and are still seeing the same result.

  3. Yes, I am using 2.6.1 on a self hosted site.

    Thank you so much for the fast response!!!

  4. OK, let's check one thing: Your wp-content/uploads directory is writable, correct?

  5. I do believe so.... I've never changed any setting with that. Where would I find that? I'm on my blog settings now to look. Would that be under "miscellaneous"?

  6. Nothing I try works... I'm forced to have to delete this until a more stable version is released :'(

  7. Hi slimhim --

    Can you create a post from the web WordPress dashboard and upload images successfully into that post ?

    If you can, please send us a URL to that post.

    The other thing to try is to create a free test blog on WordPress.com and see if you have any issues. if you don't, we know it's something specific with your self-hosted WordPress install.

  8. Yes. In fact I have to type my post on my iPhone and save as a draft online so that I can upload photos from my computer. All the post on my blog are like that. You can see it at http://www.thebestshots.com. I am hosted with 1&1. Also, it mainly happens with the photos aren't resized I noticed. I want to be able to post a 900x600 image on my blog. I will try it with the wordpress.com as well to see. Thank you!!

  9. Ok, so if I "disable" image resize in the settings menu it messes up. It does what I described in the beginning. That is from my iPhone 3GS running ios 4.1 and my iPad running ios 3.2.2 with WordPress 2.6.1 on both the Wordpress.com site and my self hosted site. If I resize the images to "large" it works fine but editing the HTML to display the images at 900x600 crashes the app when I save it. Also, if I delete a post, it still remains in my list of current post. It won't be removed. The only way to get it to remove is to reinstall the app.

  10. joshuaryanbrown
    Member
    Nov 1, 2010, 9:13 PM

    I am also having the wordpress app crash when uploading images. It will let me select an image, but then when I click upload, it crashes back to the homescreen. I have tried deleting and reinstalling the app, still nothing. I am using wordpress for iOS 2.6.1 on an iPhone 4 v4.1, wordpress.org blog. Please help. I love wordpress and really need to be able to post pictures from my iPhone! Thank you. The app looks great other than that problem.

  11. Micke Askernäs
    Member
    Nov 3, 2010, 11:07 AM

    Hello!

    I would just like to add that I am also using 2.6.1, as is a friend of mine.

    Tested on: iPhone 3GS, iOS 4.1, WordPress app 2.6.1
    Tested on: iPhone 4, iOS 4.1, WordPress app 2.6.1

    We are both using our own hosted wordpress.org blogs on our own websites.
    Both Wordpress forums are latest release 3.0.1 with image directory writeable on both systems.

    The image upload is crashing seemingly randomly. The last session, I have succesfully managed to upload images, AND take new images.

    When publishing a blogg entry, the app crashed with an error, however. Unfortunately, the error message was not captured.

    Did the same on the 3GS, but the app crashed when trying to add a picture. When restarting the phone, it seemed to work.

    This seems to depend on a lot of issues, memory usage on the phone, and how "fresh" it is after install.
    It is clear to me (as a developer (not of this app)) that there are several "random" errors occuring, and it is severely affecting mobile updates with the iPhone to wordpress.

    The instability, since we don't know if it will be published or not, when adding an image, has almost made the app unuseful for me, and for my friend.

    Not trying to bring anyone down, just trying to add some constructiveness to this.

    It also seems that it is not updating posts as it should from time to time.

    best regards,
    Micke

Topic Closed

This topic has been closed to new replies.


About this Topic