Forums

Communications Error 5 / cannot retrieve posts

  1. I hope this will help debug the App:

    I setup the app for my personally hosted blog and it is able to retrieve comments, approve comments, and add comments. However, I get a communications error box (error 5) when I try to retrieve posts - the post tab is always empty and hitting the refresh button generates the error.

    I have tested App v2.6.2 with an iPhone 4 using iOS4.0.2 and iOS 4.1. Both have the error.

    When I test App v2.6.2 with an iPod 2nd Gen running 3.1.2, I do not get the error and I can retrieve posts and update them.

  2. I have the same problem with you, and i don't know why. really puzzled

  3. I've updated the iPod Touch 2G to iOS 4.2.1 and it still works fine. the iPhone 4 is still on 4.1 and still has the error. it almost sounds like a timing issue.

  4. I solved it today by adding a new post via the ipod touch. After refreshing it. Guess what happened, they all came out. All of my past posts and the new one!! that must be a big bug!!

  5. Same error. Comments and Pages list w/o problems. Posts don't. Trying alexbeta20's solution results in several "NSXMLParserErrorDomain error 5." popping up one after the other. No posts listed. Even the test post published as "private" won't list.

    Latest WP, latest app, latest iOS on iPhone 4. WP hosted privately at http://www.strato.de on a subdomain with p/w-protection (.htaccess). XML-RPC enabled.

  6. Hey everyone, make sure you upgrade to 2.6.3 and let me know if you continue to have the same issues.

  7. Chris - 2.6.3,is working great for me. A BIG thanks to the Wordpress iOS dev and test team !

  8. So happy to hear it. I'll pass the word along!

  9. I have 2.6.3 running...

  10. I have the same problems as listed above.

    Using iOS version 2.6.3 with WordPress version 3.0.3

  11. I spoke too soon. With 2.6.3 on iOS 4.1 on iPhone 4 I created a post and added an image. It inserted hard line breaks in the middle of the HTML such that wordpress did not interpret it correctly and displayed portions of the markup in my post in place of where the image should have been.

  12. There was an error in a new library we're using to parse data that would wrap long lines of code using line breaks, this has been fixed and will be in the 2.6.4 update: http://ios.trac.wordpress.org/changeset/1299

    Sorry for the trouble.

  13. There is again this communication error NSXMLParserErrorDomain error 5. No retrieval of posts possible. Using http-auth, WP App v.2.6.6, iOS 4.2.1.

    Can anyone help me please?

  14. ralfamester -- I have the same versions as you (without http-auth) and solved the problem as follows:

    - deleted and reinstalled WP on the iPad

    - attempted to install blog, comments loaded properly but posts generated Error 5 and would not load

    - hard-closed the iPad app

    - logged into wp-admin (2.9) in a browser, added a trivial draft post (using the quick draft block at upper right)

    - reopened the iPad app, and posts loaded correctly

Topic Closed

This topic has been closed to new replies.


About this Topic