Forums

Communication Error - Bad user name or password

  1. hi! i was posting with someone last night as well with the same issue and i still don't have it resolved. i know i have a good network connection and i've tried logging with and without http://www. I've also added and not added /admin on the end to see if that will work. i can access from a brower but not from the app on the ipad which is where all my pictures are.

    i'll give you access, anything.. to get this thing working for me!!! i have a week's worth of posts sitting and waiting from a cross country road trip!

    thanks!

    jengirl1

  2. Chris, did you send an email?

  3. I did. JenGirl1, please try to keep your posts to one topic rather than posting across several topics. Did you try what I sent in the email?

  4. Sorry Chris, I'm not seeing it - you sent to the hotmail address?

  5. Setting the wp-content folder permissions to 777 (originally 755) fixed the issue for me. Thanks Chris.

  6. Just to wrap up here:

    - JenGirl1's problem was resolved by using the correct WordPress.com URL.
    - MoodBloom, sorry, in all of these posts last week we got confused. Could you give me access to your blog so I can help you troubleshoot it? You can delete me as soon as we're done! :)
    - Ryan Fitzer, that is *excellent* news! Glad to see we're squashing some of these issues. Let me know if you have any more problems.

  7. Chris, I'd be happy to give you an account, I appreciate your help. But I don't want to post a u/p here! Do you have an email address I can use?

  8. Moodboom, I sent an email to the address associated with the moodboom WordPress.com account. If that's not your account let me know. I understand you not wanting to post login info here, I don't want you to. Nor do I want to post my email address here. If you can tell me your WPcom username I'll be able to find your email.

  9. Chris,

    You posted this...

    "Hey everyone, I was just able to reproduce this several times, and I resolved it by setting permissions on my /wp-content/ folder to 777. Could everyone try doing that?"

    How can I do that?

    Thanks?

  10. Hey there Myblogaday, when you upload stuff to your WordPress installation, what FTP software do you use?

  11. Chris did you get the username I sent? Let me know if you have any troubles. Thanks again.

  12. hi chris,

    what do you mean ftp software? =(

  13. Chris you're an editor on my site. If you just try to save a draft post with any picture attached you should get the infamous error. Let me know if you get a chance to try it, and if there's anything else I can do to help.

  14. I've been having this bad user name error all along and now followed up by a different error. Have just deleted the app, redownloaded it to computer and will give it one more try. Otherwise I'll just give up on the idea until a new app is released. It's not worth cleaning up the multiple postings etc that happen when the errors occur.

  15. Hey Chris, here's a quick update. I made sure my permissions were set properly, and did one-click updates of Wordpress from 3.0 to 3.01, and all my plugins. Still getting the same "Bad username or password" error.

  16. OK fair's fair so I'm reporting back that for me, restoring the iphone after deleting the app from iPhone and computer, downloading new copy of app and putting it back on iphone seems to have done the trick. Had done that in the past so I'm not sure why it was successful this time.

  17. Thanks for the feedback mbquilts. I deleted iphone app, shut down iphone, restarted iphone, reinstalled app, same problem. It was worth a try anyway.

  18. i think the part that might have been important in my process moodboom was deleting it from both the iphone and computer and redownloading it.

  19. I just realized the wordpress iphone app is open source. I have an iphone app development environment set up, I'll try to find some time to dig into this problem when I can.

  20. I'm encounter a problem similar to the one on this thread, but with an interesting twist. I have about 10 blogs on two of my own servers (all blogs are WP 3.0.1 with minimal plug-ins - only Akismet in most cases). I have set up all the blogs in the iPad WordPress app, but am only able to change a Local Draft to Draft on three of the sites.

    On all the others I get the following error sequence when I try to save a post as "Draft" (prior to which it was "Local Draft"):

    Pop-up "Communcation Error - lost network connection" - this flashes by to the next pop-up:

    "Communication Error - Bad user name or password." with an OK button.

    If I click the okay button, I usually get the same error again.

    If I click okay again, I get "Communication Error - lost network connection" with an OK button.

    Once I click that, I'm back in the app but the app is pretty much hosed for further blog connections, and I have to switch to another app and back in to reset it.

    So I asked myself, why do those three sites work and the rest don't? I tried copying a whole working site's code and permission tree to a non-working site, only changing wp-config.php to match the original site's access information. Made no difference.

    I tried updating directly from wordpress.org using the built in updater. No difference.
    Then I went and did a completely fresh install from wordpress.org (doing a wget to grab the tar.gz file) on a new site. That didn't work.

    That left only one noticeable difference to look at on these sites. The sites for which the iPad WordPress app worked all had the Wordpress blog software in a subdirectory off the root, e.g. http://blog.richterscale.org/wp, and the ones that did not work had the blog software in the root, e.g. http://www.foodiemoment.com

    To confirm that this was the distinction, I went to the new empty blog I had just created, copied the whole thing into a subdirectory (/wp), changed the wp-config.php file to use a different database table prefix (wptest_), set up the blog with Akismet as the only plug-in, and voila I was able to post a draft from the Wordpress iPad application to the new blog, apparently solely because it was in a subdirectory instead of the root.

    So, any idea what's going on here? This would appear to be a bug of some sort.

    I'd be happy to give a moderator access to both of the new test blogs for testing/verification.

    Jake

  21. Okay, seeing as it's quiet here I figured I would do a little more debugging to help the WordPress app developers. I went and enabled logging in xmlrpc.php on both of the new sites I created - the one in the root and the one in the /wp subdirectory. I also had to add logging code to /wp-includes/class-IXR.php to capture the output from xmlrpc.php.

    Here's what a proper draft post from the WordPress iPad app looks like (password/user redacted). Input is what is sent by the WordPress app on the iPad and Output is what the server returns for the WordPress site located at http://www.bitsarecheap/wp (which works):

    2010-08-19 16:29:22  Input: <?xml version="1.0"?><methodCall><methodName>metaWeblog.newPost</methodName><params><param><value><string>1</string></value></param><param><value><string>XXXXXXXXX</string></value></param><param><value><string>YYYYYYYYY</string></value></param><param><value><struct><member><name>not_used_allow_comments</name><value><string>0</string></value></member><member><name>date_created_gmt</name><value><dateTime.iso8601>20100819T16:28:31</dateTime.iso8601></value></member><member><name>mt_keywords</name><value><string></string></value></member><member><name>wp_password</name><value><string></string></value></member><member><name>title</name><value><string>Testing5</string></value></member><member><name>not_used_allow_pings</name><value><string>0</string></value></member><member><name>description</name><value><string>This another JAKE TEST</string></value></member><member><name>post_status</name><value><string>draft</string></value></member><member><name>categories</name><value><array><data><value><string>Uncategorized</string></value></data></array></value></member></struct></value></param></params></methodCall>
    
    2010-08-19 16:29:22  Output: Post cats: array (
     0 => 'Uncategorized',
    ) 
    
    2010-08-19 16:29:22  Output: Posted ! ID: 8 
    
    2010-08-19 16:29:22  Output: <?xml version="1.0"?>
    <methodResponse>
     <params>
       <param>
         <value>
           <string>8</string>
         </value>
       </param>
     </params>
    </methodResponse> 
    
    2010-08-19 16:29:22  Input: <?xml version="1.0"?><methodCall><methodName>metaWeblog.getPost</methodName><params><param><value><string>8</string></value></param><param><value><string>XXXXXXXXX</string></value></param><param><value><string>YYYYYYYYYY</string></value></param></params></methodCall>
    
    2010-08-19 16:29:22  Output: <?xml version="1.0"?>
    <methodResponse>
     <params>
       <param>
         <value>
           <struct>
     <member><name>dateCreated</name><value><dateTime.iso8601>20100819T16:28:31</dateTime.iso8601></value></member>
     <member><name>userid</name><value><string>1</string></value></member>
     <member><name>postid</name><value><int>8</int></value></member>
     <member><name>description</name><value><string>This another JAKE TEST</string></value></member>
     <member><name>title</name><value><string>Testing5</string></value></member>
     <member><name>link</name><value><string>http://www.bitsarecheap.com/wp/?p=8</string></value></member>
     <member><name>permaLink</name><value><string>http://www.bitsarecheap.com/wp/?p=8</string></value></member>
     <member><name>categories</name><value><array><data>
     <value><string>Uncategorized</string></value>
    </data></array></value></member>
     <member><name>mt_excerpt</name><value><string></string></value></member>
     <member><name>mt_text_more</name><value><string></string></value></member>
     <member><name>mt_allow_comments</name><value><int>1</int></value></member>
     <member><name>mt_allow_pings</name><value><int>1</int></value></member>
     <member><name>mt_keywords</name><value><string></string></value></member>
     <member><name>wp_slug</name><value><string></string></value></member>
     <member><name>wp_password</name><value><string></string></value></member>
     <member><name>wp_author_id</name><value><string>1</string></value></member>
     <member><name>wp_author_display_name</name><value><string>admin</string></value></member>
     <member><name>date_created_gmt</name><value><dateTime.iso8601>20100819T16:28:31</dateTime.iso8601></value></member>
     <member><name>post_status</name><value><string>draft</string></value></member>
     <member><name>custom_fields</name><value><array><data>
    </data></array></value></member>
     <member><name>sticky</name><value><boolean>0</boolean></value></member>
    </struct>
         </value>
       </param>
     </params>
    </methodResponse>

    And here's what the server returns for the WordPress site located at http://www.bitsarecheap, which does not work for posts from the WordPress app on the iPad:

    2010-08-19 16:23:59  Input:
    
    2010-08-19 16:24:00  Input:
    
    2010-08-19 16:24:00  Input:
    
    2010-08-19 16:24:00  Input: <?xml version="1.0"?><methodCall><methodName>metaWeblog.getPost</methodName><params></params></methodCall>
    
    2010-08-19 16:24:00  Output: <?xml version="1.0"?>
    <methodResponse>
     <fault>
       <value>
         <struct>
           <member>
             <name>faultCode</name>
             <value><int>403</int></value>
           </member>
           <member>
             <name>faultString</name>
             <value><string>Bad login/pass combination.</string></value>
           </member>
         </struct>
       </value>
     </fault>
    </methodResponse>

    As can be seen above, the problem appears to be that the WordPress app just doesn't send the newPost command at all, and for the subsequent getPost, doesn't supply the necessary access information, which is what's producing the bad user/password error.

    Methinks this is definitely a WordPress app problem that needs to be addressed soon...

    Again, I'd be happy to provide necessary access to one of the moderators to both of those test blogs.

    Jake

  22. Oh - looks like the really long lines did not wrap and go off the right edge of the post - please make sure to side scroll to see them in their entirety.

    Jake

  23. Jeez. I also realized that the URLs I typed above are missing the requisite .com (e.g. http://www.bitsarecheap.com/wp and http://www.bitsarecheap.com). Sorry about that. They were entered correctly into the WordPress app, as evidenced by the fact that the app can correctly retrieve existing posts and categories on both blogs.

    Now back to y'all.

    Jake

  24. bonaireguy (Jake), nice work!!! Should make it easy for devs to fix the problem with that much good information. Thanks a lot.

  25. Has there been a resolution to this? I'm having the same problem. Have read through all the similar threads & tried various things. Nothing worked. I can upload an imageless post from my iPhone without issue, but once I try & put an image in I get the 500 error & communication error bad name/password. I've chmod'd to 777, & images are set to not resize.

    Any help would be appreciated, thanks!

    Edited to add: I see that the images I've attempted to upload appear in "/wp-content/uploads/2010/09", so the error is happening somewhere after that.

  26. Moodboom, Bonaireguy, and Dupreeblue: Would any of you be interested in joining the Beta Team so we could work on making sure this issue is definitely resolved?

  27. Chris; normally I'd say yes, but I don't think I have any business being on a WP beta team. I just did my first WP install Monday. I've got TONS of questions, issues & things I don't know yet. But I'll be as helpful as I can, and supply you w/whatever you need (if you tell me where to find it).

    Do you think our host might have something to do with it? I'm hosting my blog on 1and1, but I did my own install from the download off the WP site.

  28. dupreeblue: That makes you the PERFECT candidate to be on the Beta Team! We need input from users of all levels of experience!

    To be honest there's no way I can tell for sure unless you were to give me low-level access to your WP install as a user so I could step through what's happening. I'd much prefer for you to have the latest version, 2.6, which should be out very soon. From there we can see if your issue is resolved and if not, you could join the Beta Team and we could test further.

  29. If given that disclaimer you still want me to beta test I'd be happy to do so.

    Also: I'll be happy to give you access to my WP—if you just tell me how to do it. :)

  30. Chris,

    I would be happy to be on the Beta team for the iPad WordPress app. I would love to see this problem fixed as well as other improvements.

    Let me know what I need to do. I'd also be happy to set up a test account on any of my blogs for you to use if it will help get things to work properly.

    Jake

Topic Closed

This topic has been closed to new replies.


About this Topic