Forums

Can't upload pictures to wp blog from iPhone

  1. littlemisswitty
    Member
    Oct 29, 2011, 11:14 AM

    I'm going crazy over here. Have no idea why i can't upload any pictures to my blog, it just says "sorry, upload failed Blog returned invalid data"

    The thing is, I got two selfhosted blogs, neliz.se <-- works perfectly to upload pictures and text there via my iphone WP app. Then i got littlemisswitty.com <-- where it does not work with pictures at all. I did change the theme of that blog to see if that was the problem but nope, that didnt do anything.

    I'm not very good when it comes to technical stuff like this, hope you guys might have any ideas for what the problem might be.

    I got the latest WP update for littlemisswitty.com, might that be the problem?

    *sigh* Yup, I'm clueless right now. Help, someone? :(

  2. Take a look to this guide: http://wpiphonedev.wordpress.com/extra-debug/

    You might be able to figure out what’s wrong by yourself with just that.

  3. littlemisswitty
    Member
    Oct 29, 2011, 5:48 PM

    Wont that screw with the fact that my iPhone has an therered jailbreak on it? :/

  4. littlemisswitty
    Member
    Oct 29, 2011, 10:37 PM

    Ok, I am lost.... did everything. But WHAT exactly am I looking at in the end of the wordpress.log?
    NO other help I can get with what might be the problem???

  5. littlemisswitty
    Member
    Oct 29, 2011, 11:03 PM

    Ok, just tried to add this plugin: http://wordpress.org/extend/plugins/libxml2-fix/ but nope, that did not work either.

    Then i got the BlogPress, and yes, it does work to upload photos via that app to my blog, (which I already can from the wordpress app too but only to neliz.se and not littlemisswitty.com <--- that's my problem)

    Why does the wordpress app only work when it comes to uploading pictures to one of my two self hosted blogs? I do not get it...not at all...

  6. Did you receive any particular error messages when trying to publish a picture on littlemisswitty.com?

    Is there any error in the log file?

  7. littlemisswitty
    Member
    Oct 30, 2011, 1:28 PM

    The message i get when I'm trying to upload a picture (no matter what size it is) is: "sorry, upload failed Blog returned invalid data"

    I can't see any errors, but that's just me. Not that good when it comes to these sort of things. :/

  8. Could you please enable the "extra debug" option and try to post a picture to your blog?

  9. I'm having the exact same problem. I can't do the extra debug as I can't hook up to my laptop at the moment.

    An quick google and search of this site points out that this is rather a problem. Any idea when a fix might be ready?

  10. @gemmaholly - It is probably an issue with the upload limits on blog. Because upload limits can vary greatly from host to host and blog to blog, you can try to resize images by using a smaller size, or you can try to change the memory limits of your blog. Take a look at this FAQ: http://ios.forums.wordpress.org/topic/video-settings?replies=6

  11. I'm using wordpress.com. So is the issue that the app won't let me allow the .com host? From the web I use flickr to host my pics

  12. I'm also getting a bad login/pass message when I try to use it today.

  13. @gemmaholly - since you're on WordPress.com, it should work fine. I bet it might help for you to uninstall/reinstall the app.

  14. That was the first thing I tried. I've done it at least ten times now and still no joy. It is still crashing or giving me the bad login line.

  15. I have had the same problem since 2.9. It works fine with a wp.com blog. But not on my self hosted blogs.
    It worked with 2.8, It works with the android app.
    I have done the de-bug-logging-thing, but the log does not mention the error message as in the example.
    I sent the log anyway if it can be of any help.

    If this cannot be solved, I would be very glad if you could upload the old version of the app to app store, since it worked well for me.

    The error that always happens is: I make a post and it goes well until I upload a picture. When it reaches 100 procent the error message (blog returned invalid data) comes and the picture never uploads

    I now use the app BlogPress to insert pictures or an android phone, but I would prefer the WP iphone app.

  16. @tekatten - Could you please follow the steps below?
    - Launch the Settings app and go to WordPress settings.
    - Set the "image Resize" option to "Alway Ask".
    - Launch the WordPress app and try to upload a picture by choosing the 'Small' image size.

  17. I have done this with the same result. I have tried every possible combination of settings and image size.
    I usually resize the pictures to small ones before uploading from mobile but that does not seem to make any difference.

  18. I am having, what sounds to be, the same problem on both the iPhone and iPad. I try to upload an image and I get the following error message every time: upload fail bad login/pass combination.

    I have successfully uploaded images in the past but not tried for sometime until now. Img blog is on wordpress.COM.

    Help!

  19. @mixedgems - try to update the blog password by following the steps below:
    1. Start the app.
    2. Go to the Blogs list.
    3. Tap the Edit button.
    4. Tap the blog title.
    5. Insert the blog's password and save the changes.

    If this does not work, you might have to remove the blog and re-add it from scratch within the app.

  20. @daniloercoli Thank you so much! I did all you suggested and ended up having to delete and re-add the blogs before it would work. Prior to the deletion, the password was just not saving.

    I also learnt I could add the password via the Edit area and access the Dashboard. I had no idea!

  21. florianfriedrich
    Member
    Nov 23, 2011, 3:09 PM

    Hi,
    I have the same problem as mixedgems and littlemisswitty !
    Every time I try to upload a image withe a blog post, I get this error: "Sorry, upload failed. Blog returned invalid data."
    Did anybody find an answer to this problem? Please let me know...
    Thanks a lot!

  22. @florianfriedrich I had to delete the blogs from my mobile device and then re-add the blogs before it would work. Prior to the deletion, the passwords would not save. Try doing that. Hope it works for you.

  23. I can upload pictures again after the latest update. Problem solved. Thanks!

  24. mrsnavalonlinecom
    Member
    Dec 11, 2011, 9:11 AM

    My photos are not uploading the image from my iphone Word Press app to my wp self-hosted website. Instead it uploads some long website code. That code is what shows up on my website instead of the image. Help? Please? I reinstalled the app, logged in and out, and pulled my hair out because of frustration!

  25. I have the same problem with image uploads. Small and Medium sizes work, but large and above won't. May I ask, these sizes do not correspond to the sizes I set in WordPress under Settings - Media, correct?

    I thought it was a PHP memory issue at first too, so I've gradually increased the memory limit from 64MB, 128MB, 256MB, but nothing. Hell I've even tried 6GB but I always get the same nondescript error message "The Blog returned invalid data".

    Sadly the Extra Debug doesn't actually show anything other than that the View Controller gets opened and closed, there's just nothing in there that gives a small clue as to what's going wrong. I'm using version 2.9.3 - is there any news on this issue?

  26. I think since the last update for iOS, I'm completely locked out from uploading photos from my iPad or iPhone. the app crashes every time. No error, it just crashes. Ive tried small images. Ive deleted the app and reinstalled. Ive removed my blog and added it back. I've changed passwords. Nothing.

    PLEASE HELP.

  27. Same here. I can post text all day long, but when I try to upload ANY photo, ANY size.. all I get is that "upload failed - tap to try again"... again and again..

    I've tried adding the code in my .htaccess per the FAQ's..

    php_value memory_limit 128M
    php_value upload_max_filesize 128M
    php_value post_max_size 128M
    php_value max_execution_time 120

    ... to no avail... hell I even put it in 4 different places on my server.

    I tried the debugging & iexplorer thing, again to no avail... no viewable errors there..

    I'm using Version 3.4.1 on my site, and 3.0.1 on the iphone...

    I'm at a loss... sigh.

  28. Additional data point that might (or might not) be helpful in debugging the iOS app (or WP).

    Every attempt to upload a photo that has been edited with Camera+ or Snapseed fails with the "Upload failed - tap to retry" message, however I can successfully upload un-edited photos.

    Size seems to matter as well - 1024x1024 fails every time for edited photos, but 300x300 succeeds.

    I have implemented the php configuration changes specified above (and validated via phpinfo().

  29. OMG THANK YOU!! I'd tried everything: checked the XML-RPC, and the ATOM publishing. Also double-checked permissions, and photo uploading via desktop -- all fine. (ok well i didn't add the php.ini file)...
    but here's what worked, as advised above:
    Deleted that Blog from my iOS Wordpress app.
    Added it back.
    Voila!!

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags