Forums

Can't post via WP iOS app

  1. foodiegoeshealthy
    Member
    Jul 18, 2016, 4:49 PM

    I have been creating (and posting) blog posts through the WP iOS app for years and love the convenience. Since the last WP update, I am not able to post anything through the app-- it saves to local only and won't save a draft on the server. I tried turning the visual editor off, and still same problem. The first time I tried the error message said something about Jetpack (500 not 200 or visa versa). Please help. I am ditw (dead in the water).
    Thank you.

  2. Hi @foodiegoeshealthy,

    Sorry to hear about the trouble.

    It might be helpful if you could share with us the app's activity log. We can check the log for any error messages and clues to what's happening. You can find instructions on how to retrieve the log in this FAQ.

    In the meantime, for due diligence you might try temporarily disabling any plugins (including Jetpack) that you have installed on your site and then check to see if you can post from the app. If you can post with plugins disabled, it probably means one of them is creating a conflict. Then you can re-enable the plugins one at a time until you find the culprit.

    Hope this helps!

  3. foodiegoeshealthy
    Member
    Aug 1, 2016, 11:48 PM

    Here is the error message that I am getting. Do I need to turn on the Jetpack Json api to use the Wordpress app? Thanks so much!
    2016/08/01 11:21:46:254 Failed checking muti-author status for blog http://foodiegoeshealthy.com: Error Domain=WordPress.WordPressComRestApiError Code=6 "The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300]" UserInfo={WordPressComApiErrorCodeKey=server_error, NSLocalizedDescription=The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300], WordPressComApiErrorMessageKey=The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300]}
    2016/08/01 11:21:46:257 Failed syncing categories for blog http://foodiegoeshealthy.com: Error Domain=WordPress.WordPressComRestApiError Code=6 "The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300]" UserInfo={WordPressComApiErrorCodeKey=server_error, NSLocalizedDescription=The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300], WordPressComApiErrorMessageKey=The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300]}

  4. Hi @foodiegoeshealthy,

    Thanks for the log!

    The app can use a couple of different technologies to communicate with your blog. One is the XML-RPC API, an older technology that supports fewer features. If your blog is connected to Jetpack, the app can use a more modern technology that supports more features, the JSON API. Since we're seeing Jetpack errors in the activity log, I'm guessing there is some problem communicating with the JSON API.

    There are a couple of things we can try.

    First, yes, please make sure that the Jetpack JSON API is enabled. :)

    Second, if the JSON API was *already* enabled, or if enabling the API doesn't fix the problem, or if you'd just prefer to not enable the API for some other reason try the following:
    - Go to My Sites (the left most tab) > Your sites name > Settings
    - Use the "Remove Site" option to remove your blog from the app.
    - Sign back into your blog in the app.
    - The app should now be using the older XML-RPC API to communicate with your blog. I'd choose this option in a pinch as you'll be missing several features, including Stats and Notifications.

    The Jetpack support debug tool says your site is connected and working properly so I have my fingers crossed that enabling the JSON API module is all you'll need to do to get things working again. However, if you're still seeing errors when the JSON API is enabled let me know and we'll see what are options are.

    Cheers!

  5. foodiegoeshealthy
    Member
    Aug 2, 2016, 3:50 AM

    Eric-thanks for the reply. The app is not working yet.
    I turned on the jsonapi. Then I tried to follow your instructions above for logging out, but didn't see a remove site option at the place you suggested.
    I can see current stats, so some functions are working, but saving a new post is not.
    Any ideas? Thanks so much!

  6. > Then I tried to follow your instructions above for logging out, but didn't see a remove site option at the place you suggested

    Whoops! I forgot that with Jetpack enabled sites the sign out is in a different place. Try looking under the Me tab (the second from the right) and choose "Disconect from WordPress.com".

  7. foodiegoeshealthy
    Member
    Aug 4, 2016, 4:07 AM

    Eric- hi, me again. I logged out and then back in again on the app. I'm getting the same Jetpack error. The stats are working on the app, but the posts/pages/comments are not loading into the app.

  8. Hi @foodiegoeshealthy,

    Thanks for the follow up. Sorry that things are still not working.

    I did a bit of research and I think I can recommend the next step. The error message from the activity log read:

    WordPressComApiErrorCodeKey=server_error, NSLocalizedDescription=The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300],

    A did a little bit of hunting and found this explaination of the error on one of Jetpack's support pages:

    string(60) “-32301: transport error – HTTP status code was not 200 (500)”

    This is a server-side error from your web host. Check your PHP error log (or ask your host to) to see if there are any notices from around the time this error showed up.

    So Jetpack's support advice is to contact your web host about a server-side error and see if they can shine any light on what's happening.

    Wish I could be of more help. Fingers crossed that your host can get the issue sorted.

  9. foodiegoeshealthy
    Member
    Oct 15, 2016, 10:00 PM

    I just checked back and the app is now working correctly. I wish I knew why, but I'm happy it is.

  10. Thanks for following up. :)

  11. Hi,

    I have been having the same issue, my website hasn't been working and when I'm on the wordpress general back office it says "The Jetpack site is inaccessible or returned an error: transport error - HTTP status code was not 200 (500) [-32300]" and the website says error 500 when trying to look at it on the internet...
    Please help!

    Thank you in advance,
    Maya

Leave a Reply

You must log in to post.


About this Topic