Forums

Can't login with ios app. I can with android app

  1. Hi all,

    I tried every step offered in the FAQ section or other topics but nothing worked out so far. I still
    get the "Sorry, can't log in. Unable to find a WordPress site at that URL"message.
    When i used my husbands Android phone with the Wordpress app and the same credentials i am able to login.
    So i guess it has to be something with the ios-app. This is my site: http://www.mrsmamakelly.com

  2. Hi mrsmamakelly,

    Sorry to hear about the trouble. I took a quick look and I think I see the problem.

    When adding your blog to the iOS app, the app tries to confirm it can talk to your blog by making an XML-RPC call to your blog and then validating the response. A good response will just return XML. However, it looks like there is some other text (a PHP error message) being returned before the XML. The text reads:

    <br />
    <b>Deprecated</b>:  Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in <b>Unknown</b> on line <b>0</b><br />
    <br />
    <b>Warning</b>:  Cannot modify header information - headers already sent in <b>Unknown</b> on line <b>0</b><br />

    There is an XML-RPC validator at http://xmlrpc.eritreo.it/ that you can use to see the error yourself. Just enter your site and click "Check". Then on the next screen, click the "Show Log" link.

    The Android app is ignoring the error message from the XML-RPC response which is why you can add your blog to it. The iOS app is a bit more strict. It can ignore the error message just like the Android app, but it makes an additional check of some meta data, a certain response header returned with the XML-RPC request. Its not finding what it expects -- a header stating the content returned is XML.

    The good news is resolving the cause of the PHP error should let the iOS app work with your blog.

    First, you might try temporarily disabling any third-party plugins to see if one is causing the problem.

    If that doesn't work, you might contact your web host's support staff and see if they can help resolve the PHP error.

    Hope this helps!

  3. Hi Eric,

    I finally solved the problem thanks to you. After hours of searching on the internet i found out that my cms was using php version 5.4.45 and that version 7.0.10 would ignore certain "things"(can't remember exactly). So after i switcht to php version 7.0.10 i could login to the wp-app on my iphone. Thanks!

  4. That's great to hear!

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags