Forums

Can't Login Using 2FA

  1. I've recently enabled Single Sign on in Jetpack for my self-hosted blog that I'm connected to on my iPhone. I've also recently turned on 2 Factor Authentication for my account on WordPress.com. Ever since turning on 2FA, I've been unable to properly login to the app.

    Intrigued by this comment http://wptavern.com/wordpress-for-ios-4-0-available-new-and-improved-stats#comment-53431 , I too noticed that the iPhone app kept asking me to login to WordPress.com and no matter what I tried, it wouldn't work. After doing some research and even generating an application specific password, it still wouldn't work.

    For the first time since updating the WP iPhone app to 4.0, I logged out of WordPress.com using my Desktop, logged back in, used the keycode given to me by the Google Authenticator plugin and now, things like Stats work and the rest of the app works as well.

    So if you're having problems, I'd try logging out of WordPress.com using your desktop, and logging back in again using the Google Authenticator plugin and see if the app detects your connection to WP.com after validation.

  2. It still doesn't work with me. Do you think this can be fixed by installing the former version of the iPhone app? I can use my desktop but now I get this red and yellow warning messages in the custom mode that my " certificate is unvalid" Aaargh

  3. @hannekehofstee, Did you set up an application specific password to use with the iOS app, after enabling two-step authentication? You should use the application specific password in lieu of your normal password when signing into the app.
    http://en.support.wordpress.com/security/two-step-authentication/#application-specific-passwords

  4. Thank you for your fast reply Eric, but yes.. I did. The application connection also appeared on my admin site. I've erased it and completed the proces again. Now I have access to my WP blogs with my mobile iPhone app. I still can't view my premium site though. "The certficate of this server is not valid"...

Topic Closed

This topic has been closed to new replies.


About this Topic