Forums

Can't login at all with iOS app

  1. @Eric - Interesting that you suggest an uninstall/reinstall because I tried that before initially posting the issue. It didn't fix things. But I'll see how the updated version fairs and report back then.

  2. @Mostho I should have asked before, but just out of curiosity, which version of the app are you using?

  3. Hello Eric,
    I'm currently using the latest I think.
    V 4.4

    In iPad mini 2 and iPhone. Hope this helps...

    I have also activated the debugger mode

  4. Hello Eric,
    Good news.

    My hosting specialist found the solution:
    First I used for the testing this site and so the hosting girl
    http://xmlrpc.eritreo.it/

    She checked in the whole site and found inside file wp-config.php and said that in the header before the html tag or something similar there was an issue regardingt)the presence of a weird single character . In short this character truncated the flow and then parser was not reading exactly thus not giving access.
    What is the cause still unknown but I suspect some plug-ins like I theme security.

    Now I made a couple of testing and it works flawlessly.

    Great kudos to my hosting and to the technical support from Marialisa.

    Hope this helps also other users to have another clue about this annoying issue.

    Cheers

  5. Great news Mostho! Thanks for letting us know! :)

  6. @ceo, Version 4.5 should be available now. Any luck with the new version?

  7. I downloaded the new version today (total fluke that I'd do this on the day it's updated). I don't see anywhere a link that lets me add a self-hosted site.

    Help?

    --Jaycee

  8. @aerych - Looks like the new version fixed the issue. Hurray!

  9. After logging into the app for the first time, I had some trouble. Then I was able to connect my wordpress.org site and all the details are only showing in Wordpress.com. When I log in to Wordpress.org, I cannot see any settings to edit posts or make any changes such as customizing the site. When I try to log in to Wordpress.com on desktop, it tells me I do not have admin access to edit posts but I can see the .com posts via the app..

    Please let me know how to fix this.

  10. I'm having the same problem. I can log into one of my sites, but the other one lost the log in credentials and won't reconnect. Saying "Sorry we can't log you in. Please try entering your login details again." and i just registered another site with wordpress.com. When i try to add that site, it says the same thing even tho, i know the user and pass are correct. and can log in with them on to wordpress.com. User, password and url. same message. I'm using version 4.7

  11. Let me add to this... i can't even signin to the wordpress app at all with those log on credentials. Says they are wrong. Brand new install of the app on a device that never had it before. What am i missing.

  12. @Ridgewood2

    Hi there.

    I can log into one of my sites, but the other one lost the log in credentials [...] and i just registered another site with wordpress.com

    It sounds like you have three sites you're trying to use with the app. Is that correct?

    What are the URLs of the site that you're having trouble adding to the app?

    It sounds like you might already have one site added to the app. If so, can you walk me through the steps you're taking to add the other(s)? For instance, are you using the version of the signin screen that has a field for the site URL or the WordPress.com version that just has fields for credentials?

    Knowing these details will help troubleshoot what might be happening.

    Thanks!

  13. Yes that is correct. Ridgewoodpuppies.com, mykwebdesign.com, gardnermotors.com
    on my iphone i already have the app. and already had Ridgewoodpuppies.com and Gardnermotors.com added. I am able to connect to ridgewoodpuppies with out fail. since the 8plus ios update i can no longer access gardnermotors.net and can not add mykwebdesign.com. Both say Sorry we can't log you in. Please try entering your login details again

    On my ipad, to test i just downloaded the app. So it's a fresh install not connected to anything. i tried to connect using my mykwebdesign.com credentials. won't connect. says "Sorry we can't log you in. Please try entering your login details again". But i can log in to wordpress.com with those credentials. I then logged in using my ridgewood credentials, was able to connect but unable to add ANY sites including ridgewoodpuppies with those same credentials

    I'm using the version that has all three fields when attempting to "add a site". user, pass, URL. However, the initial login to connect to the app asks only for user and pass. I believe it's v4.7

  14. Sorry, that one URL is wrong. GardnerMotorsUsedCarSales.com. My mistake.

  15. @Erik
    I've removed Jetpack, reinstalled and reconnected.removed and reinstalled the app on Ipad - If i choose the self hosted site. It won't connect to either ridgewoodpuppies or mykwebdesign. If i just log in, i can now log into both ridgewoodpuppies AND mykwebdesign wordpress.com accounts through the app. But i can not add either site. I get that same credentials message listed above. would those two methods somehow be different login credentials?

  16. New update and I can't login either. I might as well not have a blog when you think about how much I get to update it with the app

  17. It is frustrating

  18. Hi @Ridgewood2

    Just to be sure I understand, all three of these sites are self-hosted:
    http://mykwebdesign.com/
    http://www.ridgewoodpuppies.com/
    http://www.gardnermotorsusedcarsales.com/

    And you have created one or more WordPress.com accounts to use with the Jetpack plugin installed on one or more of those sites.

    Is that correct so far?

    On my ipad, to test i just downloaded the app. So it's a fresh install not connected to anything. i tried to connect using my mykwebdesign.com credentials. won't connect. says "Sorry we can't log you in. Please try entering your login details again". But i can log in to wordpress.com with those credentials.

    This sounds like you have different credentials for your self-hosted site and the WordPress.com account you are using with it. That's fine, (and recommended).

    I then logged in using my ridgewood credentials, was able to connect but unable to add ANY sites including ridgewoodpuppies with those same credentials

    This sounds like you have separate credentials for the self-hosted sites.

    The app is designed to support multiple self-hosted accounts, and you should be able to add each of the three blogs listed above by using the same credentials you'd use to sign into those sites wp-admin, from the self-hosted signin form (the one that has the URL field). Maybe skip the Jetpack step until you've signed in with all three.

    If you have any authentication or security plugins (like a captcha, or two factor authentication) you'll want to double check those plugins do not conflict with your blogs' XML-RPC service, or in the case of a two-factor authentication plugin, if you need to use an application specific password in lieu of your normal password.

    If you've confirmed you're entering the same password in the app that works for the blog's admin in a browser, you might consider whether the password is using any unusual characters and if an alphanumeric password would work instead. The app *should* support any combination of special characters. So this suggestion is more for due diligence and in case there is some edge-case that's been over looked.

    Hope this is helpful.

  19. AderinaGraciaSharon
    Member
    Feb 9, 2015, 3:21 AM

    Hi All,
    If you turn on the 2-step auth:

    Try to login with your wordpress .COM username and app specific password. You can get the app specific password at https://wordpress.com/settings/security/.

    Tutorial for app specific password: http://en.support.wordpress.com/security/two-step-authentication/#application-specific-passwords

    It works :D

  20. I just registered a new site using hostgator.
    After linking my DNS and following all the steps to access my admin page, my wordpress dashboard is completely blank and doesn't show any perimeters.
    All I see is the left hand control panel.

    To top it off I've downloaded the Wordpress app to try and work from my iPad however it will not let me login..

    I am completely lost here.
    I'm very green in this area.

    Thank you

  21. Hi @Adawg204

    After linking my DNS and following all the steps to access my admin page, my wordpress dashboard is completely blank and doesn't show any perimeters.

    It sounds like something might not be set up correctly. If your site is not working properly then the app is likely to have trouble as well. Have you tried contacting HostGator's support staff for help setting up WordPress and your DNS?

  22. I cannot login on the ios app. I've tried deleting and re-downloading multiple times.

    I have two blogs both are on wordpress.com still. It just continuously takes me right back to the login page and I know my login information is correct. What's the point in an app if it won't work? I've complained multiple times via itunes store review and no assistance.

    My blogs are:

    http://smilemybestsmile.wordpress.com
    http://midwestcountrymusicjunkie.wordpress.com

  23. Hi twinschica,

    It just continuously takes me right back to the login page

    Can you tell me a little bit more about this? Do you mean you're able to sign in, use the app for a bit but then get sent back to the sign in screen?

    I've complained multiple times via itunes store review and no assistance.

    Ah, sorry to hear. Apple doesn't give us a way to reply to individual reviewers as much as we'd like to. :/ You can always post here in the forum, or you can use the live chat feature in the app. Its available through the Help & Support screen. You can find it by tapping on the question mark icon on the sign in screen.

    Best!

  24. janfizzashafique
    Member
    Apr 23, 2015, 7:40 AM

    How did you add the site to your device?

  25. Hi @janfizzashafique

    From the sign-in screen, you can add a self-hosted site by tapping on the "Add Self-Hosted" option.
    From within the app, you can tap on the My Sites tab, scroll down and tap on the "Add a Site" button.

    Hope this helps.

  26. I have seven sites hosted with two different companies, all wordpress.org. I can enter all of them into the WordPress app on my iPhone (4S) and can "view site" but cannot view admin. All sites require dual authentication but when the initial window comes up on the iPhone, there is no direction on what to use to log in. I tried to use my WordPress.com credentials but to no avail. I am NOT using Jetpack on any of the sites. HELP??????

  27. Hi @JSanke,

    When you tap View Admin, you are taken out of the app, and into the mobile Safari browser. You would use whatever credentials you would normally use when signing into the blog's wp-admin.

  28. I can not access any of the wordpress sites I have via the app either. I checked my xmlrpc.php in the one that I noticed this problem and it is working fine. Using iOS 8.4 and Wordpress app V. 5.3 on an iPhone 5. All give me the same error "Sorry, we can't log you in. There was a server error communicating with your site: Request failed ; service unavailable (503)"

  29. Hi @darrin,

    What's the URL to one of the blogs for which you see this happen?

  30. Hi Eric, this is one of them - http://www.audubonhillscsd.org/

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.