Forums

Cannot upload images on iOS app

  1. richardmclarke
    Member
    Feb 14, 2020, 7:34 PM

    I cannot upload images via the iOS app.

    Steps to reproduce

    Select Media
    Select +
    Select Choose from my device
    Select an image

    Result:
    Image loading progress bar completes
    Message "1 post 1 file not uploaded"

    Click retry

    Result:
    Error message "the operation couldn't be completed. (WordPressKit.WordPressComRestApiError error 7.)"

    It is a simple WordPress site with Jetpack installed.

    I have no problem uploading via the web interface

    Any help would be much appreciated

  2. Hi there!

    This normally refers to an issue with the server configurations or a plugin conflict. Would you be able to share your site address with us so we can look into this?

    If you would prefer to send this privately, you can contact us through the app by going to Me > Help & Support > Contact Us or by email at mobile-support@automattic.com.

    Thank you!

  3. richardmclarke
    Member
    Feb 18, 2020, 3:48 PM

    Hi,

    thanks for looking into this - it is lizzy-licious.com

    Cheers

  4. Hi there!

    Thanks for providing your site address. Are you connected to the app via your Jetpack connection? If so, it looks like Jetpack is having trouble communicating with your site at the moment.

    When you say you have no problem uploading via the web interface, is this from wp-admin or from https://WordPress.com/media/lizzy-licious.com?

    As a first step, would you please disconnect and then reconnect Jetpack? You can follow these instructions to do that:

    1. Go to the Jetpack menu in your dashboard
    2. Scroll down to find the *Connections* area.
    3. Click *Manage site connection*.
    4. Click **Disconnect** and follow the prompts to complete the disconnection process.
    5. Click **Set Up Jetpack** button to connect your site to WordPress.com again.

    This handy guide explains the full process in more detail:

    https://jetpack.com/support/reconnecting-reinstalling-jetpack/#disconnecting-jetpack

    If you're still having trouble after doing this, please send us a message through the app or by email so we can collect additional details regarding your site.

    Thank you!

  5. That works perfectly.

    Thanks!

  6. Glad to hear that worked! Feel free to reach out again through the apps if you run into this problem again. :)

    Cheers!

  7. I have the same problem. Would you please take a look at my site?
    friplejehjemmet-bedsted-thy.dk
    Best!

  8. btw: I have not installed Jetpack

  9. Hi @moehge,

    I did take a look at your site and it looks like in your case your host may be limiting incoming requests over XMLRPC on your server which can cause issues with this.

    Can you contact your web host and check to see if they're blocking or otherwise limiting incoming and outgoing connections over XML-RPC?

    The WordPress mobile apps, and some other plugins and services use this file to communicate with your site, but some hosts block connection requests to that file. From my testing, there is a limit set to your site and this could prevent images from uploading as the request gets blocked.

    Let us know what you find out. Thanks!

  10. Hi @rezzap - I`am have seme problem I can't add an image through the app everything works fine, over the web, but through the app I can't manage to add an image if you can help me solve the problem,

    url: sandzakhaber.net

    backticks

  11. Hi @sekki

    I've checked your site and I don't see the same issue on your XMLRPC file as listed above.

    I see your site is connected to a WordPress.com account through the Jetpack plugin though. Are you logged into the site on the app through your WordPress.com account?

    What happens exactly when you try to upload an image? Are you receiving any error messages and those this happen for any type of image you try to upload?

    It would be great if you could send the specific steps you take to upload an image for us. We can then look at why this may be happening by trying to replicate the error.

    Thank you!

  12. @rezzap givme email to send video with recording screen phone..

  13. Hi @sekki,

    You can email us at mobile-support@automattic.com or open a request from the app directly by going to ME > Help & Support > Contact us.

    This will also send us a copy of the logs of the app with details that can be helpful, so submitting through the app is ideal.

    Thanks!

  14. @rezzap : Posted but no answers for 7 days :(

  15. Hi there,

    I see your reply in our thread and I've taken a look at the details there. We're currently working through a high volume of requests and are a bit behind as we're a small team working on supporting the mobile apps.

    Normally these would be addressed within 24 hours or so under normal circumstances.

    From what I can see here we're having trouble finding your media folder and this is causing trouble with the import. Do you have any security plugins enabled on your site or anything that would affect the permissions to your media folder?

    Try disabling these plugins or confirming if any permissions on your uploads folder have been changed to see if the option to upload the images works again after changing those options.

    Thanks for your patience!

  16. Hi rezzap,

    I appreciate your team and I hope we can find a solution.

    I tried everything but the problem is not the site but the application, I even tried to download the PressSync application and add an image through it and then go back to the wordpress application and finish the blog to the end with the image I added via the PressSync application.

    I can give you access to the website if it is easier for you to find a problem, because I think it will be a solution for many.

  17. Hi there!

    I've followed up with you through email given we'll be looking at getting access to your site for testing.

    I still would like you to run the plugin test though if you can.

    Thank you!

  18. @rezzap : Please contact me to email : xsekki@gmail.com

  19. Hi there!

    I followed up with you on May 5th, but are awaiting your reply.

    Please verify your spam folder or your messages directly in the app and follow up with the details.

    Thank you!

Leave a Reply

You must log in to post.


About this Topic

Tags

No tags yet.