Forums

Cannot sync... Certificate not trusted

  1. Hello.

    I operate a website which cannot afford paying for trusted security certificates... Nor can use startcom because I goofed and cannot pay for a revoke. So I use self-signed.

    Is there any way that I can use the app still... Instead of not syncing at all... Giving a warning about certificate but giving option to continue... Like in Safari?

    This app is useless for me if this condition remains in the app and will not change.

    I appreciate feedback.

  2. Hi,

    I've got the latest app and the latest version of WP, and I have the same problem.

    However, I found a workaround. I don't know if this will work for others.

    Edit your webserver config to redirect http requests to https. Then enter the plaintext http information (ie http://www.example.com instead of httpS://www.example.com) into the Wordpress settings for the site.

    The plaintext site loads first and after that it seems to work fine over https.

    if you've set password authentication, the webserver will redirect and ask for your password before the Wordpress authentication occurs. The https authentication establishes the connection, and then the Wordpress authentication happens. Enter the info, and then the https site will load.

    Summary: leave the plaintext "http" settings in your Wordpress settings, and let the webserver handle SSL via redirect.

    Hope this helps - feedback appreciated.

Topic Closed

This topic has been closed to new replies.


About this Topic