Forums

Cannot add self-hosted blog

  1. I am unable to add my self-hosted blog to the WP app. Whatever I try, the app thinks about it for a while, then says "sorry, we can't log you in. The request timed out".

    I am trying to log in using my WP Admin credentials rather than the ones for wordpress.com (which I also tried).

    The app is connected to wordpress.com and I am logged into the app, I just cannot add a site.

    Clearly, I am doing something wrong ... but what?

    Thanks,
    Wolf

  2. Forgot to say, my site is wolfkettler.co.uk
    Have also tried adding xmlrpc.php without any success

  3. Hi @wolfkettler,

    When you type in the address for your site, try typing it as (including the /blog subdirectory):

    http://www.wolfkettler.co.uk/blog/xmlrpc.php

  4. I tried all possible variations, when I first installed the app: From the root, from the blog sub-directoryt, with and without xmlrpc - without any success.

  5. Please try signing into your blog using a private window in a browser. Are you able to get in using the username and password you are using for the app?

  6. janfizzashafique
    Member
    Apr 23, 2015, 7:44 AM

    I tried all possible variations

  7. Yes, that works in a private window.

    Wolf

  8. Hi Wolf,

    Thanks for your patience and for getting back in touch.

    I took a quick look. To test, I tried adding your blog to the app to see if I'd get the "timed out" error. For the URL I entered "www.wolfkettler.co.uk/blog/xmlrpc.php", and used a dummy username and password. Of course, I would never be able to sign in this way. However, when I tried I did not see a time out error. Instead I saw the expected error about bad credentials.

    Interestingly, if I tried "wolfkettler.co.uk/blog/xmlrpc.php" for the URL I got a different error. The app would say it could not find a site at that URL.

    The time out error you've seen can be caused by several things including a slow or spotty internet connection, problems with your web host's servers, or a web host that is blocking or throttling XML-RPC requests.

    If you're still seeing time outs, you might try switching between a cellular and wifi connection. You might also contact your web host and ask if they ever limit XML-RPC requests to WordPress sites.

    Hope this helps!

  9. Thanks for this, Eric.

    I am not getting a different message if I try the same on the PC for http://www.wolfkettler.co.uk and wolfkettler.co.uk. Hosting for the site is set up to be the same, whether with or without the www.

    Internet connection - can't be that because I connect over my Wifi connection, which works really well and is reliable.

    There is no limiting of XML-RPC requests at my hosting provider.

    In any case, I had an older version of the app on my phone (maybe a year or two ago?) and it worked sweetly. I uninstalled it when it stopped working some time ago after an update (major update, if memory serves). It did not matter then but I would have liked to use it now.

    Ah well ...

    Thanks!

  10. hope this can be fixed. Have the exact same problem with my blog for over a year now. Used to work great before...

  11. Eddycornelisse,

    What's the address of your site?

    Wolfkettler,

    Are you still having problems with the app? I notice you're using the WordFence plugin on your site and versions of WordFence prior to 5.0.3 caused conflicts with the WordPress app. Make sure you're using the latest version of WordFence.

  12. Thank you for this, Rachel, but I have decided against using the app. Clearly, there are issues with the app and I am not willing to invest any more of my time in something that does not work properly.

    Wolf

  13. eddycornelisse
    Member
    Jun 1, 2015, 9:58 PM

    Hi Rachel, somehow my response didn't make it to this forum...
    My site is hetismooiweer.nl

  14. Hi Eddycornelisse,

    I think there's a problem with the xmlrpc endpoint on your site - http://hetismooiweer.nl/xmlrpc.php

    When I test for this page using our tool at http://xmlrpc.eritreo.it/# the request times out. This can sometimes be caused by a plugin but it's more likely your host or a security module on the server blocking access.

    Try checking with your web host to see whether they block access to xmlrpc. Let us know how you get on.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags