Forums

Can’t upload images through app (‘XMLRPCApiError error 0’)

  1. I have been having this issue on my self-hosted wordpress site since I started it and I just cannot find a fix.
    Posts update ok, it’s just images. Whenever I try to upload an image from my phone I get this error:

    The operation couldn’t be completed.
    (Wordpresskit.WordPressOrgXMLRPCApiError error 0.)

    Googling this exact error comes up with users having similar XML-RPC API issues but I can’t find anything to tell me what ‘error 0’ may be. The issue itself is mentioned in older closed threads without a solution, or the solutions are outdated, from back when XML-RPC was disabled by default.

    If I login to wpadmin on chrome and bypass the app, I don’t have the issue and am able to upload images normally, so it’s just something with the app. I am about to tear my hair out over this. Making posts on mobile without using the app is a giant p.i.t.a and it’s very finicky so I really want to fix this issue.

    Things I’ve tried:

    -Renaming xmlrpc.php to xmlrpc2.php and using tbe Rename XML-RPC plugin
    -removing and adding my site multiple times, with http and https at the beginning and /xmlrpc.php at the end
    -disabling Loginizer (?) and all other plugins
    -adding this to the .htaccess file: ‘<IfModule mod_security.c> SecFilterInheritance Off </IfModule> <Files xmlrpc.php> SecFilterInheritance Off </Files>‘
    -trying smaller images

    Zilch so far. All of those things have since been reversed

    I can’t remember if I still had this issue before configuring my SSL certificate.

    Help me Obi Wan Kenobi, you’re my only hope. What can I do or what info can I give to help you help me?

  2. Did you manage to solve this? I have exactly same error and no solution :(

  3. Hi @jwarner & @jkiilune,

    There are a number of reasons that XML-RPC might be blocked, missing or not functioning correctly on a website. However, this is a service that the WordPress app does require in order to connect.

    All of the solutions mentioned by @jwarner are possible solutions, and as a first troubleshooting step we would usually recommend deactivating all plugins and seeing if you can then connect.

    This can also commonly be caused when a web hosting provider blocks XML-RPC. I would suggest checking with your hosting provider to find out if they allow XML-RPC on your site.

    To better help you with this, please go to "Me > Help & Support" in the app and tap on "Contact us", making sure to let us know the address (URL) of the site you're having problems connecting with so we can investigate it from there.

  4. Ok, i contacted my hosting service name cheap and they did open XML-RPC service for my domain. Just it doesn't work still. I keep getting Wordpresskit.WordPressOrgXMLRPCApiError error 0.

    Funny thing is that when i try to send message true app me > help & Support, I'm getting error "Message failed to send. Tap to retry. Same thing with wifi or 4g connection :S

    Im using iOS app with iPhone x

  5. Thanks for giving that a try! Do you have the latest updated version of the WordPress App installed currently?

    Can you please try deleting the app, restarting your device, and installing the app again. Once you've done that, try both connecting your website, as well as reaching the help & support messaging system once more and see if you can get through to us then.

  6. I finally managed to get it work. First my site needed jetpack plugin. Then in iphone app i needed also to be logged in to wordpress.com also to be able to upload media to my personally hosted site. Now it works like a charm!

  7. I'm glad to hear you got it working! If you encounter this problem again feel free to get back in touch and let us know :)

  8. Actually i need help a bit because my idea was so that i can post articles with my brother. Now my app is working but my brothers doesnt. Seems he cannot add same site to his wordpress.com account which i already added. He has same errors now. Is there any way he can add personally hosted site on his wordpress account?
    Or can i somehow connect him?

  9. Oh no! I'm sorry to hear you're still encountering problems getting everything set up.

    Is your brother's WordPress.com account added as an administrator (or other user role) on your website?

    I'd be happy to take a look into this and see what might be going wrong. For me to see more information about what might be going wrong, could either you or your brother please go to "Me > Help & Support" in the app and tap on "Contact us", making sure to let us know the address (URL) of the site you're having problems with and a screenshot of the error he is receiving?

Topic Closed

This topic has been closed to new replies.


About this Topic