Forums

Bugs found so far

  1. Delete a blog and button that says edit when pressed crashes the app.
    When adding a blog it's not detecting xmlrpc
    When editing xmlrpc it fails if no http:// is entered and causes errors and other problems
    Sometimes error messages appear 2 or 3 times in a row possibly linked to xmlrpc http error

    sugguestions:

    the app should look for URL/xmlrpc.php by default to minimize xmlrpc not found errors
    When adding blog XML rpc text runs past textbox if it's too long

  2. Thanks!

    Finding xmlrpc is sometimes not possible due to issues with self-hosted blogs. Failing because no http is entered is a good catch, thanks!

    I am pretty sure I'd coded a check for URL/xmlrpc.php, but will verify and add it if it doesn't exist...

    I'll also take a look at the textbox issue...

    Great testing - thanks again.

  3. I noticed that when you save to local drafts, and then you go to upload it to a self hosted wordpress blog, that if the internet goes down while you are uploading it from your iphone or touch, then the app deletes that post and you have lost it forever.

    maybe as a suggestion is that with local drafts, that it duplicates the entry or doesnt delete it from local drafts once you upload it and you have to delete it yourself??

  4. Matt (Thomas) Miklic
    Administrator
    Sep 18, 2009, 6:09 PM

    @jaccerz -- I've noticed the same behavior. I've added my findings to this ticket, where we're tracking the issue and will post more information once we've found a fix.

    http://iphone.trac.wordpress.org/ticket/152

  5. I have experienced lost posts many times with the latest wp app, like Jaccerz, but I don't think u have to be attempt to upload the post to repoduce this bug. I have been travelling in remote areas for the last 2 weeks, and am frequently writing posts "offline", without ever any attempt to upload. Sorry I don't have a systematic procedure for reproducing this, but I often switch between wp and other iPhone apps (mostly Photos). Sometimes I hit "save" and sometimes I don't. Whenever I don't it recovers my post text when i come back to wp but sometimes it doesn't have all the text. Is this my fault for not always hitting save before leaving wp? Does wp autosve the entered text periodically, and so the times when I've lost text are the times when I exit wp wo hitting save and before an autosave timer expires?

    Ok, I have another issue to report, that is more likely a bug: wp crashes whenever I save a post that has a large amount of image data to upload. It is easiest to reproduce if I turn off image resizing setting and upload more than 3 iphotos. Breaks for me every time. My workaround is to leave resize setting on (which is not nice - I like to upload highest res photos) or turn it off and limit to 3 full size photos each post (obviously annoying when you're iphotographing panoramas of Zion, Bryce Canyon, Mesa Verde and Arche NPs)

  6. Matt (Thomas) Miklic
    Administrator
    Sep 29, 2009, 8:26 PM

    @timblaktu — are you having both of these issues with the latest version downloaded from the App Store, or the limited-release 1.4 beta version sent out via email? Both of the issues you mentioned appear to be fixed in the current version in development (meaning that a fix should be available within a few weeks, when the next version is made available on the App Store).

  7. I'm not using the beta, just the latest from the app store. That's good news that they're fixed. Are the betas installed using installer app and jailbroken iphones? Haven't done that yet so maybe I'll just wait for the official release.

  8. Matt (Thomas) Miklic
    Administrator
    Oct 1, 2009, 7:19 PM

    Apple gives us a limited number of devices that can run beta versions. We'll post an announcement on our blog when we're able to add more testers.

  9. I ran into some overlapping buttons while saving a post (draft) in landscape mode. You can check out a screencap of the bug here. Once I was returned back to the post listing screen, the overlapping buttons were still there. Check out a screenshot here. When I pressed the button on top, which should have taken me back to the blog listing, the app crashed.

  10. Editing a post, I added 2 pictures and pressed save. It takes me back to the post listing page (which I think is incorrect behavior btw - more on this in a minute). When I go back to edit that post, my pictures aren't saved. They should be saved, right?

    As for the save behavior, here's my issue. I'm a compulsive saver. I've lost too much content (especially in this beta test) to risk a crash before I save. When I click save, I expect it to save my work up to that point and then let me continue editing, much like it does in the WordPress web app. Maybe there's a reason that it has to behave that way.

  11. Sorry, I have an update to the previous post I made. The images I posted aren't in the Photos area of the edit post interface, but they do show up in the preview of the post. Unfortunately this means that I when I added the photos again because I thought they were missing, I now have two sets of the same image attached to the post with no way to delete them.

    I also have a question about the preview feature. I've added a couple of different blogs to the app, but it seems like none of my themes can be retrieved by the app. Personally I think I prefer not seeing my theme cluttering up the tiny screen and be able to focus on the content that I've written. I doubt that any theme (besides an iPhone specific theme) would look decent in this sort of view at all.

  12. Ok, I'm THAT guy now.

    Am I missing something, or can you only apply custom fields to pages and not posts? I'm wondering what the thought process was behind that. I actually use custom fields more when I'm writing a post than when I'm writing a page.

  13. Ok, last one and I'm going to sleep. I'm not sure if this is a bug in the iPhone app, or with WordPress itself, but here's what I did.

    1. Publish a page that was previously a draft
    2. Check the web, page is live.
    3. Change the page status to draft again.
    4. Check the web, page is still live (if you're logged in to WordPress)

    I just noticed that this actually happens in the WordPress webapp too. If you give a page a slug (with permalinks on), it can be viewed on the web whether it's a draft or anything else. Anyone know if this is the intended behavior?

  14. @brandondove -- thanks for all the feedback. It's going to be tricky to solve in a thread with so many different items :)

    would you mind starting a new thread for each issue so we can track it down.

    thanks.

  15. @raanan - heh. sorry for the bug spew. I'll open separate topics.

  16. Okay,
    Looks like brandondove has created dedicated threads for every issue he mentioned.
    Should we consider this thread as closed?

  17. Matt (Thomas) Miklic
    Administrator
    Oct 6, 2009, 5:28 PM

    Let's give each issue its own thread. :)

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.