Blog returned invalid data

  1. Hello to all!

    I just updated my Wordpress app on Appstore to 2.7 version. Since updating i can not able to log in to my self hosted wordpress page with this application.

    It says: Sorry, can't log in,blog returned invalid data

    Username, url address and password are correct i just checked each of them.
    XML-RPC setting on my Wordpress admin is enabled!


  2. Any Idea?

  3. Having the same problem exactly - response from Wordpress was to "enter the password"!! Must have been an auto response as that's clearly not the problem

    It might be something to do with The following - wordpress claims this can cause the response we're getting. They have a validator for your site on their FAQ. However, they offer no advice on how to resolve - and don't explain why this is an issue in the updated app when it wasn't previously! Anyone?!

    Byte-Order Mark found in UTF-8 File.

    The Unicode Byte-Order Mark (BOM) in UTF-8 encoded files is known to cause problems for some text editors and older browsers. You may want to consider avoiding its use until it is better supported.

  4. Probably you have modified wp-config,php with an editor that insert the BOM at the begin of that file.
    Open that file with an open source editor such as could find the detailed istructions to clean up the files on support forum. (just use the search field with the word "bom" or "bom wordpress").

  5. Right, so we cracked it. Or rather Lartens our super web master cracked it.

    The full answer to this is at:

    Which is a lovely, working, wordpress blog now!

  6. Ps just to be clear - the app now picks up my blog whereas before it was just giving me the invalid data error. All working now! The site itself didn't seem to have any actual problems - for the ref of wordpress, still not sure why update caused this to trip up?!

  7. I did this with my wp-config.php but i still get the error "blog returned invalid data".

    I also deleted wp-config.php and went to my site to regenerate wp-config.php but I'm still getting this error message.

    Any suggestions ?

  8. Okay, works for me too. I did the following:

    - Save a copy of your wp-config php file.

    - open it with notepad ++

    - There's Format menu tab (Or coding) Choose Encode in Ansi. Then go to format again and select UTF8

    Save your file and upload to your server.

    That's all

  9. .................... sorry you have to choose UTF8 WITHOUT BOM

    And save and upload to server

  10. I've tried this with Notepad++ and it doesn't fix the problem.

  11. ok I've had a little success. I have 2 Wordpress accounts. 1 is an Administrator account that I use for installing plugins, approving comments etc and a 2nd account that has the role of editor. I can log into the Wordpress app with the administrator account but not the editor account.

    Anyone know how I can fix this ?

  12. @Towlieban - It may help to create a new user as editor and try again.

  13. I am not a programmer and don't think i have ever modified these files, especially in notepad. i am getting the same "blog returned invalid data". Is there some other explanation? I don't know which files in wp-admin to change since I haven't edited any of them.

  14. lldanj,

    The file you have to edit is wp-config.php. Follow the instructions in the link that Bedgell posted above.

  15. I've done all that's been outlined above but to no avail.

    Does anyone have any other ideas or guidance on how to fix this? Really miss being able to update remotely.


  16. did you download the latest app version (2.7.2)?
    could you please send us the URL of your blog?

  17. Yes I have the latest app and the following blogs have all returned the same results:

  18. @silverlurker -- I tested the XML-RPC endpoint of your blogs at the URLs below:

    I found errors on your blogs, the XML-RPC response is always an empty message.
    I suggest you to contact the hosting provider help desk and finding out if their default setup blocks xmlrpc.

  19. This is strange since they were working right up to my last update of the app.

  20. I am also getting the "Blog returned invalid data" error after upgrading to 2.7.2. The previous version of the app I was using was working fine with accessing my site before the upgrade.

    I do have xmlrpc enabled, I have saved wp-config.php as a UTF-8 without BOM just to make sure and yet the error continues.

    My site is , I'd appreciate any suggestions in getting the app to work again with my site. Thanks!

  21. @phink -- i hit your blog endpoint at in my browser and got an error.
    (you can check this loading that URL in your browser).

    I suggest you to try with the default theme and with no active plug-in.
    (Trying it with the default theme and plugins disabled will help pin down where the problem is. If everything works then you go back and enable your theme and then try it again. If everything still works then you go back and activate each plugin one at a time until you find the one that is causing the breakage.)

  22. @daniloercoli - Thanks so much for your quick response. I used the w3c validater earlier today and my site passed with no errors against doctype XHTML 1.0 Transitional. I did add a new plugin tonight which appears to have a few errors that I can fix swiftly (ampersand issues).

    My question is, which doctype is your app relying on when reading my site? Though it tested as perfect in XHTML 1.0 Transitional, when I then tested my site against different doctypes (html4.01 and html5), it showed errors.

    Knowing which doctype to conform to would likely help me resolve this issue. Thanks for your help on this.

  23. @phinx -- The mobile app communicates with your blog using the XML-RPC endpoint.
    You should check the XML-RPC endpoint of your blog using an xml-rpc debugger. As a first check, you can only ping the URL of the XML-RPC endpoint at in your browser.

  24. @daniloercoli - Thanks for the link and the tip. I discovered that the WP plugin Adminize was what was causing the issue. I deactivated it and the app worked. I reactivated it and the error reappeared (FYI, the error "Wrong datatype for second argument" is what was generated).

    Hope this helps you or others in the future. Thanks for helping me solve this issue!

  25. Hello All,

    I'm having the same error with my site. XML-rpc is ok. I don't have my site in the root it's actaully one folder deep. Would that make a difference?

    Any help is appreciated.


  26. Also attempted with default theme, no plugins active, and resaved my WP-comfig as UTF-8 without BOM

  27. This is still a problem for me at, any help would be highly appreciated.

  28. I've never been able to log in with this app. Error message I get is "Sorry, can't log in. Blog returned invalid data."

    • I have a self-hosted WordPress blog.
    • WordPress ver. 3.2.1.
    • iPhone OS ver. 4.3
    • WordPress for iPhone ver. 2.7
    • Default Wordpress theme.
    • No plugins installed.
    • xmlrpc.php is in login directory and has not been altered.
    • wp-config.php is in login directory and has not been altered.

    Blog is

  29. Sorry, that's WordPress for iPhone ver. 2.8.3 - 7/16/2011

    Let me add that I can't log in either as an Administrator or Editor, and never have been able to -- same error msg in both cases.

    I've tried loggin in at the base URL of the site (given above in previous post), at this URL without the /wordpress subdirectory, and at this URL with /wordpress/wp-admin/ appended.

    XML-RPC is enabled in my Admin panel. I also have tried with with default .htaccess and adding the following to .htaccess:

    <IfModule mod_security.c>
    SecFilterRemove 114

    Same exact result either way. I have read many posts and spent a few hours trying everything I can find -- no luck. I am at a total standstill with this app.

  30. Sorry for the multiple posts -- FYI, I also validated the site with the W3C Markup Validator and did not get any error like “… one or more bytes that I cannot interpret as UTF-8.″

Topic Closed

This topic has been closed to new replies.

About this Topic