Forums

bad response from XMLRPC

  1. Hi,
    I'm trying to link my blog http://www.workinggalgourmet.com to my iphone, however no matter what I try (entering workinggalgourmet.wordpress.com or http://www.workinggalgourmet.com directly) I get this message:

    "We did not get a good response from the XMLRPC endpoint URL you supplied. Please check the URL, Network Connection and try again."

    My network connection is good, and both of those web addresses work when I enter them in a brower. I've also double checked that my username and password are correct.

    What can I do to fix this?

  2. There is something odd with your setup, when I sent a test XML-RPC request I didn't get an XML-RPC response back at all, it was an HTML page (that included frames).

  3. Okay- so what do I do?

  4. Troubleshooting the set up of your self-hosted blog is outside the scope of this forum - there are lots of ways in which things can go wrong on a self-hosted blog...

    We'll try some quick things and see if we can pin it down...

    Did you set this up yourself or did you have someone do it for you? What OS are you using and do you have direct, admin-level access to the computer that is serving your blog webpages?

  5. I'm not a huge computer person, so let me see if I can fill in the blanks you need:

    1) I set up my own blog on wordpress, bought the domain name workinggalgourmet.com through Go Daddy, and set it up to forward with masking to workinggalgourmet.wordpress.com.

    2) I set this all up from my computer at work, so I have administrative control over my physical computer, but not the network it connects to.

    3) I'm using Microsoft XP Pro 2002 at work and Internet Explorer 7. We haven't upgraded due to upgrade issues (ie, i can't upgrade if that is part of your proposed solution).

    Let me know if you need anything else! I've never had this much trouble with an iPhone app before...

  6. The difficulty is in your WordPress core install, not the iPhone app...

    It sounds like you have a hosting provider... Perhaps GoDaddy? Their servers will be the on actually running the WordPress Core Server software (the blog)

    The set up of your WP Core on the remote hosted computer is odd - it's not exposing part of what is needed for the app to find the XMLRPC endpoint.

    Did your hosting provider give you a "one click" setup of WordPress or did you do a fairly complex set-up and install yourself?

  7. From what I know, I set up the two completely separately. I set up a blog on wordpress by logging in and creating the blog at workinggalgourmet.wordpress.com. Then I bought the url workinggalgourmet.com at godaddy.com. Then I simply used the tool at godaddy.com to forward workinggalgourmet.com to workinggalgourmet.wordpress.com. I chose to forward with masking.

    That was it. The two were connected no problem.

    I don't know a lot of computer jargon, so I'm not sure if I answered your question...

  8. have you tried entering your url without http or www? This may be an issue with the forwarding, but let's try that first...

    Try both your wordpress.com and workinggal urls without http or http://www...

  9. R. Scott Clark
    Member
    Dec 21, 2009, 3:46 PM

    Downloaded 2.1 for use with a wp.com blog:

    heidelblog.wordpress.com

    I get this error message repeatedly:

    "We could not find the XML-RPC service for your blog.
    Please check your network connection and try again."

  10. Scott,

    Fastest is to grant me temp access so I can watch variables in my dev environment. If that works for you, ping me at john(at)johnbickerstaff(d0t)com.

    BTW, exactly what url are you using when you enter your blog url?

  11. R. Scott Clark
    Member
    Dec 22, 2009, 2:55 AM

    Tried it again and it worked

    thx

  12. glad to hear it iw working now!

  13. I have the same problem with my blog telekta.com/blog with the iphone app. This is a self hosted site and I am not so technical. I enabled XMLRPC under settings/writting. Is there a simple troubleshooting guide for this type of problem?

  14. You have a fatal error in your setup, I tried to request http://www.telekta.com/blog/xmlrpc.php?rsd and got an error page back. You should contact your system administrator for help looking at the error logs to determine what caused the error.

  15. HELP! I don’t claim to be technically savvy but kind negotiate my way around the internet and some moderate levels of wordpress/web design. I am having a problem with the new WordPress 2 app for my iPhone 3G(s). Nothing original from what I have been seeing but it seems the solutions that are working for others are not working for me.

    My domain name and site is hosted through ICD Soft. I have uploaded and installed Wordpress 2.9. My site is up and functions well: http://www.a-gamer.com

    However I cannot get the wordpress app on my iphone to connect with my blog. I get the XML-RPC and 403 errors. I have enabled Atom Publishing Protocol and XML-RPC in the remote publishing section of the writing settings, but still no success.

    Anything else I can be doing?

Topic Closed

This topic has been closed to new replies.


About this Topic