Forums

App Crashes on Setup

  1. Hi, I'm trying to add the blog artistsontheroad.com to Wordpress 2.1 on my iPhone 3GS, and the app crashes every time.

    The xmlrpc.php link is exactly as in the example on the FAQ page, and everything else seems as though it's working correctly.

    The blog is on WPMU 2.9.1

    Any help?

  2. Are you getting a specific error message or does the app crash without one?

  3. Nope, no error message. It just quits after giving me the "Validating Blog..." spinner for about 10 seconds.

    If I put in an incorrect password or username, it gives me the following error:

    Communication Error: Bad user name or password

    So it's crashing after the account verification.

  4. The app is getting something it can't digest from your xmlrpc endpoint -- or a configuration error on the server is giving trouble... Those are the most likely explainations.

    I've checked and I can get a good response from your xmlrpc endpoint using HTTP Client. I can't do much more troubleshooting than that without access to the blot so that I can test some other xmlrpc method calls and see what comes back (this is what the app does when it tries to add the blog)

    If you're willing to give me temporary access, I'll try to pin down the source of the error... your choice of course...

    One thing to try is to turn off all plugins and use the default theme - that will eliminate the possibility of errors in custom php causing this...

    Ping me at john(at)johnbickerstaff(d0t)com if you're interested in me doing a little more indepth troubleshooting...

  5. Got your e-mail - I'm testing a few things...

  6. I wonder if this could be the issue? The file mentioned is the xmlrpc method call that's coming back empty when I test your blog

    http://trac.mu.wordpress.org/ticket/1195

    Let me know if this helps...

  7. I have installed the 3.01 beta on Webfaction in two flavors, single and multiple user.

    The single-user version I am able to connect using the iPhone app. The multi-user version I have tried with the default theme, with plugins off etc. In every case the app verifies user/pass (putting in the wrong one gives an error) but after spinning it simply crashes.

    I tried this on iphone and iPad with the same result. I looked at the crash logs but saw nothing I could decipher.

    Any suggestions?

    thanks

    Damon

  8. I work at a newspaper Web site, and all our blogs seem to have the same problem when trying to connect via the new iPad app. The app quits after giving the Validating Blog notice. If I use a wrong ID or password, I get the "bad user name or password" error. With the correct login, it crashes every time. We are also on WordPress MU, which we keep up to date with the latest version. Here are a couple of blogs that I've tested: http://blog.timesunion.com/capitol and http://blog.timesunion.com/philipmorris. Any ideas what we can do? --Paul Block, executive producer, timesunion.com

  9. Hi Paul --

    Any plugins that you are running that you think might be interacting ? Are you able to use other apps that use XMLRPC with your blogs ? Such as Microsoft Livewriter or Mars Edit ?

  10. Ipstenu (Mika Epstein)
    Member
    Apr 14, 2010, 12:22 AM

    I'm having the exact same problem as dkiesow - It ONLY happens on multi-site (using last night's SVN).

    Per raanan's comment, I downloaded Mars Edit and that works fine.

  11. Ipstenu (Mika Epstein)
    Member
    Jun 29, 2010, 2:33 PM

    Updating because, guess what? Still fails on WP 3.0 multisite.

Topic Closed

This topic has been closed to new replies.


About this Topic