Forums

App can't see my catagories

  1. briandowlingtv
    Member
    Sep 26, 2014, 8:44 AM

    Hi all

    New here.

    Ive been using wordpress for years now but new to the iOS app.

    I want to make a blog post but when trying to select the category, like blog category it shows now catagorys at all.

    Any help would be treaty appreciated

    Regards
    Brian

  2. Hi Brian. The app should show the list of categories for your blog. If the list is still showing up blank you might try disabling any plugins to see if one is causing a conflict with the app.

  3. Following up...

    Curious if you're using the Jetpack plugin? If so it might explain why categories are showing up empty.

    There is an issue where the categories data returned by a site with the Jetpack plugin can be missing a couple of important fields. The Jetpack folks are are of the bug and working on a fix.

  4. I've been suffering with the same problem since the iOS8 update. In my case it only seems to affect sites hosted by Fasthosts. I get a server error message: “Temporary Server Error. It seems your Wordpress site is not accessible at this time, please try again later.” The post does upload, but there's no categories list, so no way to actually publish.

    I don't use Jetpack.

    I hope you can help.

    Jeff

  5. @ Jeff

    Are you able to share the URL of one of the affected sites?

  6. constantine.cornwall.sch.uk

    If you have a secure email I could give you a login.

  7. By the way, I should say that I've duplicated constantine.cornwall.sch.uk on a non-Fasthosts test server and your app works perfectly.

  8. By the way, I should say that I've duplicated constantine.cornwall.sch.uk on a non-Fasthosts test server and your app works perfectly.

    This plus the type of error message suggests the problem lies with something about how Fasthosts has configured their servers. I suggest contacting their tech support and asking them to check your site's error logs to see if they can identify the cause. Also ask them if they are doing anything to block XML-RPC requests, as this would also interfere with the app.

  9. I tried another test post from the iOS app this morning and checked the server log. Same problems and only two log entries:

    81.135.77.49 - - [02/Oct/2014:10:17:13 +0100] "POST /wp-admin/admin-ajax.php HTTP/1.0" 200 47 "http://constantine.cornwall.sch.uk/wp-admin/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10) AppleWebKit/600.1.22 (KHTML, like Gecko) Version/8.0 Safari/600.1.22"

    81.135.77.49 - - [02/Oct/2014:10:17:43 +0100] "POST /xmlrpc.php HTTP/1.0" 200 180 "-" "wp-iphone/4.3.1 (iPhone OS 8.0.2, iPhone) Mobile”

    It seems to me there should more entries. Posting from a browser results many more entries as the various Wordpress system and plugin files are accessed.

  10. @ Jeff,

    This category issue is bugging me. Since you offered, maybe I could try inspecting the call as it happens from within the app and see if any clues to what's happening turn up. If you have a test user with editor access that you're willing to share you could email the credentials to mobile at automattic dot com. Make it to my attention and reference this forum thread to help make sure it gets routed my way.

  11. @Jeff

    Thanks for sharing the credentials. As it turns out, I wasn't even able to make use of them.

    I tried querying your blogs XML-RPC endpoint: http://constantine.cornwall.sch.uk/xmlrpc.php This is the page the app uses to communicate with your site. When I tried, I was only able to make a successful call maybe once out of fifteen tries. The majority of the time the request failed with a HTTP 503 error.
    http://www.checkupdown.com/status/E503.html While testing I used both the app, a tool called XMLRPC Client, and just refreshing the page in a web browser. Same result all around.

    With the luck I had I'd be amazed if the site in question could function in the app at all.

    It still looks like the cause of the problem is due to how the server is configured. I don't have any new clues from the test but I'm curious if host has some restriction on XML-RPC requests.

    Sorry I couldn't be more help.

  12. Thanks Eric

    You've confirmed what I had suspected. I've had trouble in the past with Fasthost's somewhat over zealous defence against brute force attacks. I guess this may be related. I'll pass on your comments to them, but in the end it may just be simpler to switch hosts. Thanks for your help.

    By the way Wordpress is wonderful. Thanks for that too!

  13. Eric

    One last nugget of information in case it's of interest. I believe Fasthosts use NGINX and FASTCGI. I've suffered from repeated NGINX errors on their sites in the past because they limit logins.

    I've checked their PHP environment and they have PHP_FCGI_CHILDREN set to 0 and PHP_FCGI_MAX_REQUESTS set to 100. Could this be contributing to our problem?

    None of this is really your problem, but just in case you're curious: http://constantine.cornwall.sch.uk/phpinfo.php

    Thanks again. Jeff

  14. Eric

    We've now switched hosts on constantine.cornwall.sch.uk. The 503 errors are gone, but we're still missing the categories page on the app. I've tried disabling plugins and changing themes. Can you take another look using the login details I gave you?

    Jeff

  15. Hi Jeff,

    Sorry for the delay replying. There is certainly some weirdness going on.

    Using the credentials you provided, I tested both on a real iPhone and also in the iPhone simulator. In both cases I signed in and tapped on posts > new post icon > options > categories, and saw a list of categories.

    What was strange was the list was different on the device vs the simulator. On the device I saw 44 categories, in the simulator I saw 24. Its going to take some more digging to figure out what's going on, but we're looking. You can follow along here: https://github.com/wordpress-mobile/WordPress-iOS/issues/2573

    One last thing... it looked like you were using version 4.3.1 of the iOS app in the server logs you posted earlier. Have you tried upgrading to 4.4?

  16. Hi Eric

    Thanks for looking into this. When I look under Updates 4.3.1 seems to be the latest version shown. I'm not sure how to get 4.4.

    I don't know if this helps, but I found a work around which has been effective on several different devices which were not showing a category list. Adding a new category on the device seems to refresh the list and show all the categories.

    I can't figure out how to delete the newly added category. If I delete it via a browser it remains on the device where it was added. There doesn't seem to be a category delete function within the app.

  17. When I look under Updates 4.3.1 seems to be the latest version shown. I'm not sure how to get 4.4.

    Oops. I misspoke. The current version in the app store *is* 4.3.1. We submitted 4.4 a while ago but apparently there were some delays getting Apple to approve it. My bad.

    I can't figure out how to delete the newly added category. If I delete it via a browser it remains on the device where it was added. There doesn't seem to be a category delete function within the app.

    That sounds like a bug. Deleting categories from the app is not a feature yet but if you delete a category from your blog it should also be removed from the app when your blog's data is synced. I've added this to our list of issues
    https://github.com/wordpress-mobile/WordPress-iOS/issues/2574

Topic Closed

This topic has been closed to new replies.


About this Topic