Forums

PHP Memory Settings (Video Upload)

  1. Because upload limits can vary greatly from host to host and blog to blog, we wanted to make sure to give you our recommended settings for WordPress.org users who would like to use the new video feature.

    If you’re running WordPress 2.9.2 or later please be sure to add the following lines to your root .htaccess file:

    php_value memory_limit 128M
    php_value upload_max_filesize 128M
    php_value post_max_size 128M
    php_value max_execution_time 120

    We will be working with some of the bigger hosts to determine if we can get these set automatically for WordPress.org users. I'll also be working with all of you to determine what tweaks might need to be made for each of your blogs.

  2. Also, I built an alternative in 2.6.1 for people that are unable to upload videos using the default XML-RPC method. If you enable the Atom Publishing Protocol in Settings > Writing > Remote Publishing, then go to the Settings app on your iPhone, click WordPress, and change the Video API setting to AtomPub, you should be able to upload videos if you were having trouble with the previous method.

  3. Thanks for the info. For reference, I've always been told by hosting providers to put those lines of code in a php.ini file. If I put them in the .htaccess file, should they go between # BEGIN WordPress and #END WordPress, or after?

  4. Thanks for the info. For reference, I've always been told by hosting providers to put those lines of code in a php.ini file. If I put them in the .htaccess file, should they go between # BEGIN WordPress and #END WordPress, or after?

    +1

  5. Has this worked for anyone? I'm trying to upload the htaccess file to my host (Bluehost) now and it seems to be taking forever. I hope this fixes things.

  6. I cant get Video to work at all with the app. Always says, Upload fail, tap to try again. Tried a thousand times...

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags